Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4919 closed defect (fixed)

iptables seems to be broken

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

in rev r15174 everything worked fine .. now with rev 15198 i get this error with iptables when i start shorewall ....
iptables: Bad rule (does a matching rule exist in that chain?)

ERROR: Command "/usr/sbin/iptables -D INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT" Failed

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by puchu

i got the same error and investigated a little bit and found out that Changeset 15177 is causing this behaviour removing trunk/target/linux/generic-2.6/patches-2.6.28/110-netfilter_match_speedup.patch fixes shorewall startup and everything works as expected ... so please revert changeset 15177...

comment:2 Changed 9 years ago by rbiz

I can confirm that this is indeed not limited to this case. Stateful filtering seems to be broken? Not sure if it's related, but ipt_state is missing in my build.

comment:3 Changed 9 years ago by rbiz

deleting that patch didn't do it for me.

this is somehow connected to #4673 and feels like it has something to do with the new iptables version which relies on newly named modules which aren't properly flagged in the menuconfig

comment:4 Changed 9 years ago by rbiz

works for me now - don't know exactly how. i was playing around with the makefile to add various netfilter-related modules which were deselected. i'm not sure which one did the trick, but there's the solution

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 9 years ago by anonymous

fresh r15938 and not working, having problems dowloading from ftp sites using pppoe even with mtu fix (asus wl500gp)

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.