Modify

Opened 12 years ago

Closed 12 years ago

#491 closed defect (fixed)

S60olsrd hangs boot sequence (S99done is never executed)

Reported by: Wallace78 Owned by: florian
Priority: normal Milestone: 0.9/rc6
Component: packages Version:
Keywords: Cc:

Description

... so the firstboot process isn't started and the jffs2 fs never created.
This happens with all custom images created with ImageBuilder.

Attachments (1)

olsrd.postinst (84 bytes) - added by fabian.deutsch@… 12 years ago.
postinst file to fix DebugLevel problem

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 12 years ago by fabian.deutsch@…

This happens, because thhe default olsrd.conf contains the line:
"""
# Debug level(0-9)
# If set to 0 the daemon runs in the background

DebugLevel 1
"""
so this prevents olsrd from daemonizing and consequently not running anything after the olsrd init script.

Maybe this line should set to "DebugLevel 0" or the olsr init.d script should start olsrd in background.

Changed 12 years ago by fabian.deutsch@…

postinst file to fix DebugLevel problem

comment:3 Changed 12 years ago by florian

  • Resolution set to invalid
  • Status changed from assigned to closed

I confirm, setting DebugLevel to other values than 0 makes the daemon run in foreground mode.

comment:4 Changed 12 years ago by florian

  • Resolution invalid deleted
  • Status changed from closed to reopened

Default behaviour is now fixed in [3816]

This prevents the issue mentions below.

comment:5 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.