Modify

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#4859 closed defect (wontfix)

lighttpd webdav module fails

Reported by: kralikba@… Owned by: nico
Priority: normal Milestone:
Component: packages Version:
Keywords: lighttpd-mod-webdav uuid Cc:

Description

On an NSLU2 using download.openwrt.org's packages, lighttpd fails to start if the webdav module is enabled with the following message:
lighttpd: can't resolve symbol 'uuid_unparse'
If I compile and install the svn version, I get nearly the same error except for the missing symbol is 'uuid_generate'.

uname -a:
Linux Anschluss-F 2.6.26.6 #17 Sun Feb 15 00:54:31 CET 2009 armv5teb unknown

opkg list_installed:
base-files-ixp4xx - 14-r14511 -
bridge - 1.4-1 -
busybox - 1.11.2-2 -
dnsmasq - 2.46-1 -
dropbear - 0.51-2 -
fconfig - 20080329-1 -
firewall - 1-1 -
glib1 - 1.2.10-1 -
hostapd-mini - 0.6.6-1 -
hotplug2 - 0.9+r102-2 -
iptables - 1.4.0-1 -
iptables-mod-conntrack - 1.4.0-1 -
iptables-mod-nat - 1.4.0-1 -
ixp4xx-microcode - 2.4-2 -
kernel - 2.6.26.6-ixp4xx-1 -
kmod-fs-ext3 - 2.6.26.6-ixp4xx-1 -
kmod-ipt-conntrack - 2.6.26.6-ixp4xx-1 -
kmod-ipt-core - 2.6.26.6-ixp4xx-1 -
kmod-ipt-nat - 2.6.26.6-ixp4xx-1 -
kmod-ipt-nathelper - 2.6.26.6-ixp4xx-1 -
kmod-madwifi - 2.6.26.6+r3314-ixp4xx-2 -
kmod-ppp - 2.6.26.6-ixp4xx-1 -
kmod-pppoe - 2.6.26.6-ixp4xx-1 -
kmod-scsi-core - 2.6.26.6-ixp4xx-1 -
kmod-usb-core - 2.6.26.6-ixp4xx-1 -
kmod-usb-storage - 2.6.26.6-ixp4xx-1 -
kmod-usb2 - 2.6.26.6-ixp4xx-1 -
libapr - 1.2.9-1 -
libaprutil - 1.2.8-1 -
libexpat - 1.95.8-1 -
libgcc - 4.1.2-14 -
libiconv - 1.9.1-1 -
libintl - 0.16.1-4 -
liblua - 5.1.4-2 -
libncurses - 5.6-1 -
libneon - 0.28.2-1 -
libopenssl - 0.9.8i-3 -
libpcre - 7.6-2 -
libpthread - 0.9.29-14 -
libreadline - 5.2-1 -
libsqlite3 - 3.5.9-1 -
libuci - 0.7.3-1 -
libuci-lua - 0.7.3-1 -
libuuid - 1.40.11-1 -
libxml2 - 2.7.2-3 -
lighttpd - 1.4.20-3 -
lighttpd-mod-webdav - 1.4.20-3 -
lua - 5.1.4-2 -
luci-admin-core - 0.8.6-1 -
luci-admin-full - 0.8.6-1 -
luci-admin-mini - 0.8.6-1 -
luci-app-firewall - 0.8.6-1 -
luci-cbi - 0.8.6-1 -
luci-core - 0.8.6-1 -
luci-http - 0.8.6-1 -
luci-i18n-english - 0.8.6-1 -
luci-ipkg - 0.8.6-1 -
luci-sgi-cgi - 0.8.6-1 -
luci-sys - 0.8.6-1 -
luci-theme-base - 0.8.6-1 -
luci-theme-openwrt - 0.8.6-1 -
luci-uci - 0.8.6-1 -
luci-uvl - 0.8.6-1 -
luci-web - 0.8.6-1 -
mc - 4.6.1-2 -
mtd - 8 -
opkg - 4564-3 -
ppp - 2.4.3-10 -
ppp-mod-pppoe - 2.4.3-10 -
sqlite3-cli - 3.5.9-1 -
subversion-client - 1.5.2-2 -
subversion-libs - 1.5.2-2 -
subversion-server - 1.5.2-2 -
uci - 0.7.3-1 -
uclibc - 0.9.29-14 -
udevtrigger - 106-1 -
wireless-tools - 29-2 -
zlib - 1.2.3-5 -

It is a fresh install, no hacks have been done except for the necessary pivot_root hack.

Attachments (1)

lighttpd.patch (477 bytes) - added by kralikba 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by kralikba

Solution:
modify Makefile:
add --with-locks to CONFIGURE_ARGS
add UUID_LIB="-luuid" to CONFIGURE_VARS

Changed 9 years ago by kralikba

comment:2 Changed 9 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to assigned

comment:3 Changed 9 years ago by WooDzu

Sorry, but on Linux MyBook 2.6.17.14 #1 PREEMPT Mon Mar 26 12:36:33 BST 2007 armv5tejl GNU/Linux with Lighttpd 1.4.22 the patch doesn't work.

comment:4 Changed 9 years ago by nico

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [15830], thanks for reporting!

comment:5 Changed 8 years ago by jus7incase@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is still an isse with
lighttpd-mod-webdav 1.4.20-3
on
Firmware OpenWrt Kamikaze - With X-Wrt Extensions 8.09
Kernel Linux 2.6.25.20 #8 Mon Jan 25 11:40:58 CST 2010
Board i586
Web mgt. console Webif²
Version r4838

comment:6 Changed 8 years ago by Justin Case <jus7incase@…>

Please consider OpenWRT sers that are not able or willing to recompile stuff and just use packages out of the box. Is there a fix for this issue on this level? I already installed sqlite3 cli and libuuid etc, but that didn' fix it.

comment:7 Changed 7 years ago by hauke

  • Resolution set to wontfix
  • Status changed from reopened to closed

Please use backfire, we do not support kamikaze any more.

comment:8 Changed 7 years ago by anonymous

Backfire or trunk...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.