Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#481 closed defect (fixed)

busybox 1.1.1 and 1.1.2 don't work - mount and more applets not found (trunk r3639)

Reported by: tristan@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc: tristan@…


I'm trying to run the latest trunk on an Aruba AP70, built on Fedora Core 2. busybox doesn't seem to work properly. In particular mount doesn't work, which means that I can't boot properly (can't remount filesystem read-write, or mount /proc).

I tried downgrading to busybox 1.1.1 but that doesn't help. busybox 1.1.0 works (I had to revert to busybox as of trunk r2977). busybox 1.1.1 and 1.1.2 build successfully, but it appears that some of the applets don't work.

This is what I get when I run busybox 1.1.2:

BusyBox v1.1.2 (2006.04.13-22:04+0000) Built-in shell (ash)                     
Enter 'help' for a list of built-in commands.                                   
  _______                     ________        __                                
 |       |.-----.-----.-----.|  |  |  |.----.|  |_                              
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|                             
 |_______||   __|_____|__|__||________||__|  |____|                             
          |__| W I R E L E S S   F R E E D O M                                  
 KAMIKAZE (bleeding edge, r3639) -------------------                            
  * 10 oz Vodka       Shake well with ice and strain                            
  * 10 oz Triple sec  mixture into 10 shot glasses.                             
  * 10 oz lime juice  Salute!                                                   
root@(none):/# mount                                                            
mount: applet not found                                                         
root@(none):/# less
more: applet not found
root@(none):/# busybox --help
BusyBox v1.1.2 (2006.04.13-22:04+0000) multi-call binary

Usage: busybox [function] [arguments]...
   or: [function] [arguments]...

        BusyBox is a multi-call binary that combines many common Unix
        utilities into a single executable.  Most people will create a
        link to busybox for each function they wish to use and BusyBox
        will act like whatever it was invoked as!

Currently defined functions:
        [, [[, arping, ash, awk, basename, bunzip2, busybox, bzcat, cat,
        chgrp, chmod, chown, chroot, clear, cp, crond, crontab, cut, date,
        dd, df, dirname, dmesg, du, echo, egrep, env, expr, false, fgrep,
        find, free, grep, gunzip, gzip, halt, head, hexdump, hostid, hostname,
        id, ifconfig, init, insmod, ipcalc, ipkg, kill, killall, killall5,
        klogd, length, ln, lock, logger, logread, ls, lsmod, md5sum, mesg,
        mkdir, mkfifo, mktemp, more, mount, mv, nc, "netmsg", netstat,
        nslookup, passwd, pidof, ping, pivot_root, poweroff, printf, ps,
        pwd, rdate, reboot, reset, rm, rmdir, rmmod, route, sed, seq,
        sh, sleep, sort, strings, switch_root, sync, sysctl, syslogd,
        tail, tar, tee, telnet, test, time, top, touch, tr, traceroute,
        true, udhcpc, umount, uname, uniq, uptime, vi, wc, wget, which,
        xargs, yes, zcat


Any ideas? This is pretty serious for me since it means I can't boot... :-(

Attachments (1)

busybox-config (14.5 KB) - added by tristan@… 12 years ago.
my busybox config

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by kaloz

  • Cc tristan@… added
  • Milestone set to 2.0

Try a clean checkout. It's working flawlessly here.

comment:2 Changed 12 years ago by tristan@…

A clean checkout of what? busybox or the whole kamikaze trunk? I did a make distclean before submitting this bugreport and I haven't touched anything in package/busybox. Can you please show me your busybox config? Perhaps there is something wrong with mine... (see attached)

Changed 12 years ago by tristan@…

my busybox config

comment:3 Changed 12 years ago by anonymous

Try removing your .config and run make menuconfig again.

comment:4 Changed 12 years ago by tristan@…

Yes, that seems to work - thanks!

comment:5 Changed 12 years ago by mbm

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.