Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#476 closed defect (duplicate)

compile conflict with madwifi for Atheros

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description

I have conflict with -mips3 and -MIPS32. Can this be resolved in openwrt files? Or do I have to edit manualy?
I use OpenWrt as is from svn (kamikaze) and only change to kernel for Atheros in make menuconfig.
Btw: Is this the way to post issues like these, or is there an other way to go through?

For more detail: bart.swinnen@…

/home/swinnenb/openwrt/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DKERNEL -I/home/swinnenb/openwrt/trunk/openwrt/build_mips/linux-2.4-ar531x/linux-2.4.32/include -Wall -Wstrict-prototypes -Wno-trigraphs -Os -fno-strict-aliasing -fno-common -fno-builtin-sprintf -fomit-frame-pointer -funit-at-a-time -I /home/swinnenb/openwrt/trunk/openwrt/build_mips/linux-2.4-ar531x/linux-2.4.32/include/asm/gcc -G 0 -mno-abicalls -fno-pic -pipe -finline-limit=100000 -mabi=32 -march=r4600 -Wa,-32 -Wa,-march=r4600 -Wa,-mips3 -Wa,--trap -DMODULE -mlong-calls -fno-common -include ./../include/compat.h -I./../include -isystem /home/swinnenb/openwrt/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-/include -I./../hal -I./../hal/linux -I./../ath_hal -I./.. -DAH_BYTE_ORDER=AH_BIG_ENDIAN -G 0 -EB -mno-abicalls -fno-pic -Wa,--trap -mips32 -fno-strict-aliasing -fno-common -fomit-frame-pointer -mlong-calls -DATH_SUPERG_FF=1 -DATH_SUPERG_DYNTURBO=1 -DATH_TURBO_SCAN=1 -DATH_SUPERG_XR=1 -nostdinc -iwithprefix include -DKBUILD_BASENAME=ah_osdep -DEXPORT_SYMTAB -c ah_osdep.c
mips-linux-uclibc-gcc: unrecognized option `-EB'
ah_osdep.c:1: error: -mips32 conflicts with the other architecture options, which specify a MIPS3 processor
make[11]: * [ah_osdep.o] Error 1
make[11]: Leaving directory `/home/swinnenb/openwrt/trunk/openwrt/build_mips/linux-2.4-ar531x/madwifi-ng-r1486-20060329/ath_hal'
make[10]:
* [_mod_/home/swinnenb/openwrt/trunk/openwrt/build_mips/linux-2.4-ar531x/madwifi-ng-r1486-20060329/ath_hal] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 12 years ago by kaloz

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #330

comment:2 Changed 12 years ago by mbm

  • Milestone set to 2.0

comment:3 Changed 5 years ago by anonymous

how to solve? can you show the melod

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.