Modify

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#4754 closed defect (fixed)

ntfs-3g not working on brcm47xx

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: packages Version:
Keywords: Cc:

Description

I have SATA hdd in external case connected to my WL-500gP with USB. Hdd has 2 ntfs partitions. After connection with ntfs-3g all seem to be OK, but when I use command "ls -la /path/to/mount_point", this command doesn't responding & terminal freezes. Partitions are correctly displayed with "fdisk -l"

system: Kamikaze 8.09 v14548, mips - brcm47xx, Asus WL-500gP v1

log (dmesg):
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
fuse init (API version 7.9)
usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 0:0:0:0: Direct-Access Maxtor 6 Y472055E YAR5 PQ: 0 ANSI: 2 CCS
sd 0:0:0:0: [sda] 320173056 512-byte hardware sectors (163929 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 38 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] 320173056 512-byte hardware sectors (163929 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 38 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through

sda: sda1 sda2

sd 0:0:0:0: [sda] Attached SCSI disk
usb-storage: device scan complete

mount log:
/dev/sda1 on /pokus type fuseblk (rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096)

Attachments (2)

2.6.36__170-kmod-fuse-dcache-bugfix.patch (2.2 KB) - added by bud.dhay@… 7 years ago.
2.6.37__170-kmod-fuse-dcache-bugfix.patch (2.2 KB) - added by bud.dhay@… 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by bud.dhay@…

check out

/ticket/5186.html

bud

comment:2 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with [16413].

comment:3 Changed 7 years ago by bud.dhay@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

this happens again with newer kernels 2.6.36+, because the old patches for brcm47x do not apply anymore

comment:4 Changed 7 years ago by bud.dhay@…

because the issue ist still pending, sent the attached patches three times to openwrt-devel@… (first on 16th of january), i'll attach them here as well...

these patches consolidate the former

301-kmod-fuse-dcache-bug-r4k.patch
302-kmod-fuse-dcache-bug-fuse.patch

of which 302 is missing in trunk's /target/linux/brcm47xx/patches-2.6.{36,37} . this leads to the reappearance of the DCACHE bug on brcm47xx platforms using these kernels (listing a fuse mount point hangs indefinitely).

replacing the current half of the patch (301) in /target/linux/brcm47xx/patches-2.6.{36,37} with the attached patches will fix the issue. the number was raised to bring it closer to other patches modifying r4k cache.

please add to trunk. regards bud

Changed 7 years ago by bud.dhay@…

Changed 7 years ago by bud.dhay@…

comment:5 Changed 7 years ago by hauke

  • Resolution set to fixed
  • Status changed from reopened to closed

Thank you for the patch.

This is fix again in r26141.

comment:6 Changed 7 years ago by bud.dhay@…

thanks, finally. any reason why you separated it again into two patches? also i moved it further up to be closer to other r4k patching and minimize probability of patch insert break.

bud

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.