Modify

Opened 9 years ago

Closed 7 years ago

Last modified 4 years ago

#4730 closed defect (duplicate)

wireless stops working when under load (brcm47xx on wrt54g 2.2)

Reported by: maltesch@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Kamikaze trunk
Keywords: brcm47xx wrt54g b43 hostapd Cc:

Description

Hello,
I (try to) use Kamikaze with target brcm47xx. I have been having trouble since I switched from kernel 2.4 which is that everything works fine as long as I don't put load on the wireless interface.
Under load the wireless subsystem stops working after some seconds to a few minutes (no data is transmitted and clients loose association after some time). There is nothing strange in the logs.
If the problem happens it helps to kill hostapd and start it again, or to do a wifi down/up cycle.

The latest SVN version I tried is r14744. I use WPA2 with PSK and the smaller hostapd-package.

I attached my .config.

Attachments (0)

Change History (19)

comment:1 Changed 9 years ago by maltesch@…

ok, the bugtracker regards my .config as spam .. so no .config.

comment:2 Changed 9 years ago by hauke

This is a known bug with the b43 module. It is not working really nice in AP mode.
You can try some other firmware for the b43 module and try if it works better with that.

comment:3 Changed 9 years ago by maltesch@…

Good to know that this problem is at least known. I switched back to kernel 2.4 for the moment. I tried different firmwares in the past, but none solved the problem.
If there are patches I could test just let me know.

comment:4 Changed 9 years ago by ylxu

I meet the same issue on WRTSL54GS with SVN ver r14606. Windows XP under high traffic (such as P2P app) trigger the bug, and it can solved temporary with reboot the hostapd process. My another laptop (Thinkpad T61 with Intel 3945) run Fedora 10 is very stable with it, so I think the issue is hostapd only, not the b43 module.

comment:5 in reply to: ↑ description Changed 9 years ago by Martin

I can confirm this. Stops working under load, no suspicious dmesg output, just stalled. Restarting hostapd restores wifi connection on my WRT54G v2.2 as well.

comment:6 Changed 9 years ago by gerd94706@…

Another me too:
The symptoms I am experiencing are consistent with the description of this ticket.
The only difference is: The bug shows on my WRT54G even if there is little or no traffic.
Also, my box reads "version 3", but I understand there is not much of a hardware
change compared to version 2.2.
The system works for about 20minutes to 1 hour and then stops working until
I either reboot or restart hostapd.
Unlike the original submitter, I cannot try out patches, since I do not have
access to a cross-development environment.

Also, I noticed that wireless "option hidden" is silently ignored.
But since I am new to OpenWRT, I do not know if it had been like this
for a long time or more recent behavior.
But that should probably go into another trouble-ticket.

comment:7 Changed 9 years ago by maltesch@…

I cannot say for sure yet, but r16356 looks much better, I did not manage to trigger the problem till now.

comment:8 Changed 9 years ago by ericew@…

wl500gpv2 seems to exhibit the same behavior under 8.09.1, r16278 ( brcm-2.4 ). It will run for a few minutes properly after a reboot and then stop running completly or slow to a crawl. I am running it in client mode with psk.

comment:9 Changed 9 years ago by ericew@…

After the third or fourth reflash the problem for me seems to have disappeared.

comment:10 Changed 9 years ago by linux@…

I see this problem too. I have tried to reflash 8.09.1 a number of times, but wifi dies after 10-15 minutes. Everything else in the box works.

comment:11 Changed 8 years ago by thepeople

  • Version set to Kamikaze trunk

Please try this on trunk.

comment:12 Changed 8 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:13 Changed 7 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

comment:14 Changed 7 years ago by anonymous

Still having this problem under 10.03 with WRT54GL 1.1 when using more than one wireless device. PSK2 for encryption.

comment:15 follow-up: Changed 7 years ago by nbd

What do you mean by 'when using more than one wireless device'?

comment:16 in reply to: ↑ 15 Changed 7 years ago by anonymous

Replying to nbd:

What do you mean by 'when using more than one wireless device'?

What I meant was I usually just use my laptop on wireless. Whenever I also connect my android phone, the wireless would go down.

I actually have to correct that: This now happens without the second wireless device, just not as often. The second wireless device will absolutely make it happen within a minute or so but by itself, the router will drop the wireless link sometime overnight usually.

comment:17 Changed 7 years ago by anonymous

Upon even further googling, this issue seems to be a duplicate of /ticket/7552.html

comment:18 Changed 7 years ago by nbd

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:19 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.