Modify

Opened 9 years ago

Closed 7 years ago

Last modified 20 months ago

#4710 closed defect (fixed)

MiniPCI device causes all other PCI devices to dissapear in 2.6 not 2.4

Reported by: eric-junk@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description (last modified by rmilecki)

The title says it all. This has been tested on an ASUS WL500W (BCM4707). When using a Ubiquiti Networks SR-71A (AR9160) and:


KAMIKAZE (bleeding edge, r13655)

Linux OpenWrt 2.4.35.4 #3 Mon Dec 22 00:53:38 MST 2008 mips unknown
# lspci -vv -s 01:02.0 -k -xxxx -q
01:02.0 Network controller: Atheros Communications, Inc. AR9160 802.11abgn Wireless PCI Adapter (rev 01)
        Subsystem: Device 0777:4082
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 2
        Region 0: Memory at 40010000 (32-bit, non-prefetchable) [disabled] [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=100mA PME(D0+,D1-,D2-,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 8c 16 27 00 00 00 b0 02 01 00 80 02 00 00 00 00
10: 00 00 01 40 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 77 07 82 40
30: 00 00 00 00 44 00 00 00 00 00 00 00 02 01 00 00
40: 80 80 00 00 01 00 82 48 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

# lspci
00:00.0 FLASH memory: Broadcom Corporation Sentry5 Chipcommon I/O Controller (rev 09)
00:01.0 Ethernet controller: Broadcom Corporation Sentry5 Ethernet Controller (rev 09)
00:02.0 Ethernet controller: Broadcom Corporation Sentry5 Ethernet Controller (rev 09)
00:03.0 USB Controller: Broadcom Corporation Sentry5 USB Controller (rev 09)
00:04.0 PCI bridge: Broadcom Corporation Sentry5 PCI Bridge (rev 09)
00:05.0 MIPS: Broadcom Corporation BCM3302 Sentry5 MIPS32 CPU (rev 09)
00:06.0 Modem: Broadcom Corporation BCM47xx V.92 56k modem (rev 09)
00:07.0 Network and computing encryption device: Broadcom Corporation Sentry5 Crypto Accelerator (rev 09)
00:08.0 RAM memory: Broadcom Corporation Sentry5 DDR/SDR RAM Controller (rev 09)
01:00.0 Host bridge: Broadcom Corporation BCM4704 PCI to SB Bridge (rev 09)
01:02.0 Network controller: Atheros Communications, Inc. Device 0027 (rev 01)
01:03.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
01:03.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
01:03.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)                    

KAMIKAZE (bleeding edge, r14654)

Linux OpenWrt 2.6.28.7 #6 Thu Feb 26 22:09:17 MST 2009 mips unknown

nothing.
(output of lspci is blank, nothing in /sys/bus/pci/)


WITHOUT the card installed:

KAMIKAZE (bleeding edge, r14654)

Linux OpenWrt 2.6.28.7 #6 Thu Feb 26 22:09:17 MST 2009 mips unknown
# lspci
00:00.0 Host bridge: Broadcom Corporation BCM4704 PCI to SB Bridge (rev 09)
00:03.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
00:03.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
00:03.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)

The problem is that I need to use the ath9k driver with this card. ath9k is only available for 2.6, but when I run a 2.6 kernel, the card - and I guess the entire PCI bus - completely disappears. It's visible in 2.4 - but I have no driver!

I installed the SR-71A card into my laptop running a 2.6.27 kernel. The card was detected just fine. The card also works with a recent version of DD-WRT, which runs a recent 2.6 kernel. I have posted a topic on the ubiquiti networks forums, but I feel like this seems to be a bug with openwrt.

Help!

Attachments (0)

Change History (15)

comment:1 Changed 8 years ago by anonymous

Same problem for me.
Sparklan WMIA-199N AR9160+AR9106 + WL500W

comment:2 Changed 8 years ago by frej

Also, it's KAMIKAZE (bleeding edge, r17696)

comment:3 Changed 8 years ago by yjdofc@…

Just same with the Buffalo wzr-g54 wirelessrouter(BCM4704/4M/64M RAM/bcm5325A2KQM)+Atheros AR9160(MB82) mini-PCI card.

comment:4 Changed 8 years ago by towolf <towolf@…>

And the same with Senao EMP-7605 AR9220 802.11N.

Could it actually be increased power draw in these cards?

comment:5 Changed 8 years ago by florian@…

Still happens with backfire and a Atheros 9223!
with a 2.4 Kernel i can see the atheros card with the lspci command.
lspci on 2.6 is just plain empty!

comment:6 Changed 8 years ago by florian@…

BUT: Card is being normally detected on brcm47xx-2.6 kamikaze 7.09 (visibile @ /sys). But not on 8.09!

comment:7 Changed 8 years ago by mazonovo@…

Same problem here with Asus WL500G-P V1 and TL-WN861N (AR9223) ATH9k. I'm using KAMIKAZE (bleeding edge, r21446) - 2.6.32.12 and putting lspci returns just nothing.

Any solution for this problem?

comment:8 follow-up: Changed 7 years ago by jow

  • Version set to Trunk

Please try this patch in target/linux/brcm47xx/patches-2.6.34/998-pci_delay.patch:

--- a/drivers/ssb/driver_pcicore.c
+++ b/drivers/ssb/driver_pcicore.c
@@ -370,7 +370,7 @@ static void ssb_pcicore_init_hostmode(st
 	set_io_port_base(ssb_pcicore_controller.io_map_base);
 	/* Give some time to the PCI controller to configure itself with the new
 	 * values. Not waiting at this point causes crashes of the machine. */
-	mdelay(10);
+	mdelay(300);
 	register_pci_controller(&ssb_pcicore_controller);
 }
 

comment:9 in reply to: ↑ 8 ; follow-up: Changed 7 years ago by anonymous

Replying to jow:

Please try this patch in target/linux/brcm47xx/patches-2.6.34/998-pci_delay.patch:

--- a/drivers/ssb/driver_pcicore.c
+++ b/drivers/ssb/driver_pcicore.c
@@ -370,7 +370,7 @@ static void ssb_pcicore_init_hostmode(st
 	set_io_port_base(ssb_pcicore_controller.io_map_base);
 	/* Give some time to the PCI controller to configure itself with the new
 	 * values. Not waiting at this point causes crashes of the machine. */
-	mdelay(10);
+	mdelay(300);
 	register_pci_controller(&ssb_pcicore_controller);
 }
 

I was able to reproduce this bug on a Asus wl-500w with a TP-LINK TL-WN861N (rev 2.0) card. This patch solved my problem. 'lspci -v' no reports properly and 'wifi detect' works correctly and my wireless no comes up in n mode with wpa2.

Thanks!

comment:10 in reply to: ↑ 9 Changed 7 years ago by anonymous

Let me fix my typos:

I was able to reproduce this bug on a Asus wl-500w with a TP-LINK TL-WN861N (rev 2.0) card. This patch solved my problem. 'lspci -v' now reports properly and 'wifi detect' works correctly and my wireless now comes up in n mode with wpa2.

Thanks!

comment:11 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for your feedback. I added the patch in r22614.

comment:12 Changed 7 years ago by anonymous

appears this patch did not make it into rc3 of 10.03.1

comment:13 Changed 7 years ago by jow

Are you sure? I merged it three weeks ago (r22614). It should be in.

comment:14 Changed 7 years ago by jow

I meant r22615

comment:15 Changed 20 months ago by rmilecki

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.