Modify

Opened 9 years ago

Closed 9 years ago

#4572 closed defect (duplicate)

make world build fails in /target-mipsel_glibc-2.7/host/bin/libtool

Reported by: richard@… Owned by: developers
Priority: normal Milestone:
Component: toolchain Version:
Keywords: libtool Cc:

Description

Building for bcm47xx

libtool fails during makeworld in (line 340):

build_dir/target-mipsel_glibc-2.7/opkg-4564

because "global_symbol_pipe" is empty in "export_symbols_cmds".

To allow compile to succeed, changing the following line works-

from (line 340):
export_symbols_cmds="\$NM \$libobjs \$convenience | \$global_symbol_pipe | \$SED 's/.* ' | sort | uniq > \$export_symbols"

to (line 340):
export_symbols_cmds="\$NM \$libobjs \$convenience | \$SED 's/.* ' | sort | uniq > \$export_symbols"

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by florian

Can you please submit a patch using svn diff and attach it ?

comment:2 Changed 9 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #4389

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.