Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4569 closed defect (worksforme)

error compiling kismet

Reported by: nosilent_ Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: kismet error Cc:

Description

hello everybody, i'm getting an error while compiling the latest openwrt kamikaze svn source.

make[3]: Entering directory `/home/r00t/8.09/feeds/packages/net/kismet'
make -C /home/r00t/8.09/build_dir/mipsel/kismet-2008-05-R1 LD="\$(CC)" all
make[4]: Entering directory `/home/r00t/8.09/build_dir/mipsel/kismet-2008-05-R1'
mipsel-linux-uclibc-g++ -I/home/r00t/8.09/staging_dir/mipsel/usr/include -I/home/r00t/8.09/staging_dir/mipsel/include -I/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++ -I/home/r00t/8.09/build_dir/linux-brcm47xx/linux-2.6.25.17/include -O2 -Wall -DVERSION_MAJOR=\"2008\" -DVERSION_MINOR=\"05\" -DVERSION_TINY=\"R1\" -DTIMESTAMP=\"cat TIMESTAMP\" -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -fno-builtin -fno-rtti -nostdinc++ -c speech.cc -o speech.o
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base: In constructor 'std::single_associative<Key, ValueType, Compare, Allocator>::single_associative(const Compare&, const Allocator&, const typename std::base_associative<Key, ValueType, Compare, Allocator>::key_type (*)(typename std::base_associative<Key, ValueType, Compare, Allocator>::value_type)) [with Key = mac_addr, ValueType = std::pair<mac_addr, wireless_client*>, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]':
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/map:108: instantiated from 'std::map<Key, T, Compare, Allocator>::map(const Compare&, const Allocator&) [with Key = mac_addr, T = wireless_client*, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]'
tracktypes.h:270: instantiated from here
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base:502: error: invalid conversion from 'const mac_addr (*)(std::pair<mac_addr, wireless_client*>)' to 'mac_addr (*)(std::pair<mac_addr, wireless_client*>)'
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base:502: error: initializing argument 3 of 'std::base_associative<Key, ValueType, Compare, Allocator>::base_associative(const Compare&, const Allocator&, Key (*)(ValueType)) [with Key = mac_addr, ValueType = std::pair<mac_addr, wireless_client*>, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]'
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base: In constructor 'std::base_associative<Key, ValueType, Compare, Allocator>::base_associative(const Compare&, const Allocator&, Key (*)(ValueType)) [with Key = mac_addr, ValueType = std::pair<mac_addr, wireless_client*>, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]':
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base:502: instantiated from 'std::single_associative<Key, ValueType, Compare, Allocator>::single_associative(const Compare&, const Allocator&, const typename std::base_associative<Key, ValueType, Compare, Allocator>::key_type (*)(typename std::base_associative<Key, ValueType, Compare, Allocator>::value_type)) [with Key = mac_addr, ValueType = std::pair<mac_addr, wireless_client*>, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]'
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/map:108: instantiated from 'std::map<Key, T, Compare, Allocator>::map(const Compare&, const Allocator&) [with Key = mac_addr, T = wireless_client*, Compare = std::less<mac_addr>, Allocator = std::allocator<wireless_client*>]'
tracktypes.h:270: instantiated from here
/home/r00t/8.09/staging_dir/mipsel/usr/include/uClibc++/associative_base:78: error: invalid conversion from 'mac_addr (*)(std::pair<mac_addr, wireless_client*>)' to 'const mac_addr (*)(std::pair<mac_addr, wireless_client*>)'
make[4]: * [speech.o] Error 1
make[4]: Leaving directory `/home/r00t/8.09/build_dir/mipsel/kismet-2008-05-R1'
make[3]:
* /home/r00t/8.09/build_dir/mipsel/kismet-2008-05-R1/.built Error 2
make[3]: Leaving directory `/home/r00t/8.09/feeds/packages/net/kismet'
make[2]: * [package/feeds/packages/kismet/compile] Error 2
make[2]: Leaving directory `/home/r00t/8.09'
make[1]:
* /home/r00t/8.09/staging_dir/mipsel/stamp/.package_compile Error 2
make[1]: Leaving directory `/home/r00t/8.09'
make: * [world] Fehler 2

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this error.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.