Modify

Opened 9 years ago

Closed 9 years ago

#4559 closed defect (worksforme)

"Build/install java compiler and GNU classpath" causes compilation error on trunk

Reported by: mk144210@… Owned by: florian
Priority: normal Milestone:
Component: toolchain Version:
Keywords: Cc:

Description

This is the current error on trunk:

/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc: In function 'void catch_segv(int, siginfo_t*, sig_ucontext_t*)':
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc:149: error: 'struct sigcontext' has no member named 'sc_pc'
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc: In function 'void catch_fpe(int, siginfo_t*, sig_ucontext_t*)':
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc:163: error: 'struct sigcontext' has no member named 'sc_pc'
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc: In function 'jint _Jv_CreateJavaVM(JvVMInitArgs*)':
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc:1274: error: 'NR_sigaction' was not declared in this scope
/home/misha/src/openwrt/trunk/build_dir/toolchain-mipsel_gcc-4.1.2_uClibc-0.9.29/gcc-4.1.2/libjava/prims.cc:1278: error: '
NR_sigaction' was not declared in this scope

Not sure if this is the problem:
http://lists.uclibc.org/pipermail/buildroot/2008-April/008303.html

Thanks for hard work and getting past previous error with new gcc.

Misha

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

I cannot reproduce this bug here, my build machine is a debian testing amd64, what is yours ?

comment:2 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing this ticket since I cannot reproduce it. Re-open if needed.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.