Modify

Opened 9 years ago

Closed 8 years ago

#4551 closed defect (duplicate)

division problems with php in ar71xx snapshot packages

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Kamikaze trunk
Keywords: Cc:

Description

Doing this works correctly, displaying 2:

echo 20 / 10;

This displays -0:

echo 20 / 11;

And this causes php to hang, terminating after 30 seconds:

echo 10 / 20;

Not sure what's causing it. I haven't tested php or php-cgi, I'm using php-fastcgi. I've tested this on command line and within lighttpd.

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by anonymous

Forgot to mention, this is using Kamikazi 7.09 with php5-fastcgi_5.2.6-2_mips.ipk dated 01-Feb-2009 19:20 @ 873K

comment:2 Changed 9 years ago by anonymous

I'm getting the same problem with php5-cli and php5-cgi

comment:3 Changed 9 years ago by anonymous

http://downloads.openwrt.org/kamikaze/8.09_RC2/ar71xx/packages/

I also tried with the php5-fastcgi package there and had the same problem. I'll see if there's another location to test division & floating point to see if it's php or something else.

comment:4 Changed 9 years ago by anonymous

Yes, it's the floating point numbers in PHP.

$blah = 1.23232;
echo $blah;

Will result in displaying something very strange.

echo 1.2222;

Will display 0

comment:5 Changed 9 years ago by anonymous

I was wrong about the version; I was using a snapshot. I've updated to 8.09RC2 and reinstalled all the packages; same problem.

comment:6 Changed 9 years ago by anonymous

Please close this ticket; I'm going to start a new one, since this is about floating point, not strictly division.

comment:7 Changed 8 years ago by rhk

  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to Kamikaze trunk

Duplicate of #4560

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.