Modify

Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#4523 closed defect (duplicate)

No broadcom monitor mode on WRT54GL

Reported by: Belfry Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: monitor Cc:

Description

Thanks to Florian for answering ticket #4515.

This is what I have in /etc/config/wireless

config wifi-device wl0

option type broadcom
option disabled 0

config wifi-iface

option device wl0
option mode monitor

No monitoring tools work, there is no prism0 interface (even after "ifconfig wl0 up" and "wlc monitor 1") and iwconfig reboots the machine. If I run "iwconfig wl0" the output indicates managed mode.

Any help would be much appreciated.

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by florian

Did you manage to put the interface in monitor mode differently ? Using wl or wlc ?

comment:2 Changed 9 years ago by Belfry

Hi Florian. I cannot get it into monitor mode at all. Under the 2.4 broadcom driver in 7.09 "wlc monitor 1" creates a new virtual interface called prism0 and you direct any monitoring application to use this interface (just as in these links:AircrackHowToAirsurfer's answer.)
Under 8.09 either of these will produce prism0 but any attempt to monitor or running iwconfig reboots the machine (just as in ticket #4182.) Using "option mode monitor" in /etc/config/wireless blocks the creation of prism0, but still results in machine reboots.

I really like the client-mode CPU performance in 8.09 vs 7.09, so I'm hoping to stay with it.

comment:3 Changed 9 years ago by Belfry

Hi Florian,

Any progress on this? I have posted my attempts to resolve this herehttp://forum.openwrt.org/viewtopic.php?id=18616 Can you provide any insight as to where the problem might lie?

comment:4 Changed 8 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4182

comment:5 Changed 5 years ago by Viktor

I'm successfully using aircrack-ng on WRT54GL 1.1 with OpenWRT Kamikaze 7.09 wrt54g-2.4 . It is necessary to enter commands in this order (cited from Airsurfer's answer in AircrackHowTo - according to Belfry advice sooner in this ticket):

wl monitor 1
ifconfig wl0 up
iwconfig wl0 txpower 5mW
airodump-ng wl0
airodump-ng prism0

Airodump-ng is not able to change channel. You must change channel yourself with command:
wl channel "6"

and then start airodump-ng with this channel:
airodump-ng prism0 --channel "6"

Obviously, it is not possible to scan channels with this configuration.

comment:6 Changed 5 years ago by anonymous

Note: I have just observed that 'wl' must be copied to RAM (/tmp). It is sufficient to copy wl file to /tmp. Otherwise airodump-ng returns:

Error setting monitor mode on prism0

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.