Modify

Opened 9 years ago

Closed 9 years ago

#4519 closed defect (fixed)

hostapd 0.6.7 is incompatible with 2.6.25 kernel

Reported by: thomas@… Owned by: developers
Priority: normal Milestone: Bugs Paradise
Component: packages Version:
Keywords: hostapd, 2.6.25, 2.6.28 Cc:

Description

After commit 14227 or so, hostapd has been updated to 0.6.7. However, 0.6.7 includes new nl80211 functionality that will break with 2.6.25 and probably needs 2.6.28 (2.6.27 maybe, not sure).

I only changed the version number and md5sum back to 0.6.6 and wireless worked again (the socket filter patch still applies and works, meaning hostapd CPU usage is lower, but softirq usage is unchanged).

This is all tested with trunk as of yesterday evening on a brcm47xx (WRT54GL v1.1), b43 wifi.

The solution is to either update to >=2.6.27 so we are able to use a newer compat-wireless or to leave hostapd at 0.6.6 if mac80211 wireless is used.

See also: http://forum.openwrt.org/viewtopic.php?pid=80621#p80621

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by KanjiMonster

This is what you get for using trunk ;).
The 8.09 branch is still at hostapd 0.6.6 (and probably will stay there), so this is a non-issue for 8.09, but still applies to trunk. Although I think we can expect that bcm47xx will be eventually upgraded to 2.6.27+, especially since there are already patches for 2.6.28.

comment:2 Changed 9 years ago by anonymous

Ah, okay, I only looked at trunk.

A bit more detail for anyone who is interested:

First, hostapd fails to set the country code. That is non-fatal, so I patched hostapd to ignore the failure. But then, I got "Unable to update rate sets for kernel module", and I gave up then, assuming that too many things had changed in the nl80211 interface.

comment:3 Changed 9 years ago by agb

  • Milestone changed from Kamikaze 8.09 to Kamikaze Bugs Paradize

8.09 is still using hostapd 0.6.6 as noted above, moving milestone.

comment:4 Changed 9 years ago by thomas@…

This can be closed: 8.09 uses 0.6.6, trunk is upgraded to 2.6.28 (at least for the platform I use) where 0.6.8 is supported flawlessly.

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.