Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4491 closed defect (fixed)

ntpclient fails due to missing librt

Reported by: oliver@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

r14165 on an AR7 platform:

root@OpenWrt:~# ldd ntpclient
	librt.so.0 => not found
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2aaee000)
	libc.so.0 => /lib/libc.so.0 (0x2ab3d000)
	ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2aaa8000)
oliver@flux:~/openwrt/kamikaze-trunk$ grep -i librt .config
# CONFIG_PACKAGE_librt is not set

Seems like the ntpclient package is missing a dependency?

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with [14174].

comment:2 Changed 9 years ago by anonymous

I just ran into this again. The patch seems to be against ntpdate, not ntpclient. You may want to do something similar for ntpclient.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.