Modify

Opened 12 years ago

Closed 12 years ago

#442 closed defect (wontfix)

micro image of rc5 provides ipkg-sh, which is obsolete

Reported by: rudy Owned by: developers
Priority: high Milestone: 0.9/rc6
Component: base system Version:
Keywords: ipkg ipkg-sh dependencies ar Cc:

Description

The micro image of rc5 provides ipkg-sh, instead of ipkg offered by the other images. The ipkg-sh version has been obsoleted by its developers (see http://www.handhelds.org/moin/moin.cgi/Ipkg).

The ipkg-sh script does not provide support for ar-based ipkg packages. Furthermore, it has a bug in handling dependencies for packages provided as a file instead of part of a repository. The program does not pull in dependencies from the repositories when required by the package installed from file (or url). See also http://forum.openwrt.org/viewtopic.php?id=4112&p=9.

Finally, from a more philosophical point of view, the two releases should contain the same packages, since they are both labeled rc5. The situation now dictates releasing the micro image under a different name.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by kaloz

  • Resolution set to wontfix
  • Status changed from new to closed

ipkg-sh is used due to the fact, that it's smaller then the normal one. And the naming convention comes from the targetted devices.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.