Modify

Opened 9 years ago

Closed 9 years ago

#4414 closed defect (fixed)

NanoStation2 image generated by revision 13820 is broken

Reported by: anonymous Owned by: juhosg
Priority: high Milestone:
Component: kernel Version:
Keywords: Cc:

Description

The image generated using OpenWrt r13820 briked my NanoStation2. Now it doesn't even flashes the Ubiquiti firmware :O

Any significant change in the script that creates the image?

With revision 13338 it works fine.

Attachments (0)

Change History (10)

comment:1 follow-up: Changed 9 years ago by anonymous

Your problem...

comment:2 in reply to: ↑ 1 Changed 9 years ago by anonymous

Replying to anonymous:

Your problem...

Not just my problem, in the Ubiquiti forum there was the same report.

Thanks very much for your help :/

I saw that the tool used by openWrt to build the images for the NanoStation2 has changed. Before that change it worked fine.

comment:3 Changed 9 years ago by juhosg

  • Component changed from packages to kernel
  • Owner changed from developers to juhosg
  • Priority changed from normal to high
  • Status changed from new to assigned

comment:4 Changed 9 years ago by anonymous


I've seen in the values in https://dev.openwrt.org/browser/trunk/tools/firmware-utils/src/mkfwimage.c?rev=13859 for rootfs and kernel are the same. Is this correct?

.name = "XS2",
47 .kern_start = 0xbfc30000,
49 .root_start = 0xbfc30000,

comment:5 follow-up: Changed 9 years ago by juhosg

The rootfs_start is wrong, definitely. Although it is not used, because the tool computes it automatically [1], i will fix it.

  1. https://dev.openwrt.org/browser/trunk/tools/firmware-utils/src/mkfwimage.c?rev=13859#L246

comment:6 in reply to: ↑ 5 Changed 9 years ago by Sebastian D. Criado

Replying to juhosg:

The rootfs_start is wrong, definitely. Although it is not used, because the tool computes it automatically [1], i will fix it.

  1. https://dev.openwrt.org/browser/trunk/tools/firmware-utils/src/mkfwimage.c?rev=13859#L246

And if not used. Why is the present?

comment:7 Changed 9 years ago by sebastian.criado@…

I wondered if this problem can rewrite part of the partition setup of "RedBoot" and, in this case, not be load the kernel. And if this patch can resolv this problem.

Thanks very much for your help

comment:8 Changed 9 years ago by anonymous

Is this issue fixed? I've to flash a NS with Kamikaze trunk, but I want to know before I do it.

comment:9 Changed 9 years ago by Sebastian D. Criado

Is this issue fixed?
This patch can resolv this problem?: https://dev.openwrt.org/changeset/14404/trunk/tools/firmware-utils/src/mkfwimage.c

comment:10 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Yes this issue is fixed, I just checked it today with a Nanostation.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.