Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4389 closed defect (worksforme)

opkg compile error: ../libtool: eval: line 4350

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: opkg compile error Cc:

Description

when I compile opkg package, I get some errors as follows, can anyone else help me or give some advice to me, thanks in advance!
the error as follows(opensuse 11):

chj@linux-xzlr:trunk\> TOPDIR=pwd make -C package/opkg/ V=99
make: Entering directory `/opt/chjdoc/fos/trunk/package/opkg'
make: Warning: File `/opt/chjdoc/fos/trunk/staging_dir/toolchain-i386_gcc4.1.2/info.mk' has modification time 3.9e+04 s in the future
WARNING: skipping opkg -- package not selected
make -C /opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564 CC="ccache i386-linux-uclibc-gcc" DESTDIR="/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/ipkg-install" all install
make[1]: Entering directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564'
Making all in libbb
make[2]: Entering directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libbb'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libbb'
Making all in libopkg
make[2]: Entering directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libopkg'
make all-am
make[3]: Entering directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libopkg'
/bin/sh ../libtool --tag=CC --mode=link ccache i386-linux-uclibc-gcc -Wall -Werror -DHOST_CPU_STR=\"i386\" -DBUILD_CPU=i586 -DLIBDIR=\"/usr/lib\" -DOPKGLIBDIR=\"/usr/lib\" -DDATADIR=\"/usr/share\" -I.. -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -fpic -I/opt/chjdoc/fos/trunk/staging_dir/i386/usr/include -I/opt/chjdoc/fos/trunk/staging_dir/i386/include -I/opt/chjdoc/fos/trunk/staging_dir/i386/usr/lib -L/opt/chjdoc/fos/trunk/staging_dir/toolchain-i386_gcc4.1.2/lib -L/opt/chjdoc/fos/trunk/staging_dir/i386/usr/lib -L/opt/chjdoc/fos/trunk/staging_dir/i386/lib -L/opt/chjdoc/fos/trunk/staging_dir/i386/usr/lib -Wl,-rpath-link,/opt/chjdoc/fos/trunk/staging_dir/i386/usr/lib -o libopkg.la -rpath /usr/lib -export-symbols-regex "opkg_.*" args.lo libopkg.lo user.lo opkg_state.lo opkg.lo opkg_cmd.lo opkg_configure.lo opkg_download.lo opkg_install.lo opkg_upgrade.lo opkg_remove.lo opkg_conf.lo opkg_utils.lo pkg.lo pkg_depends.lo pkg_extract.lo hash_table.lo pkg_hash.lo pkg_parse.lo pkg_vec.lo file_util.lo opkg_message.lo md5.lo sprintf_alloc.lo str_util.lo xregex.lo xsystem.lo conffile.lo conffile_list.lo nv_pair.lo nv_pair_list.lo pkg_dest.lo pkg_dest_list.lo pkg_src.lo pkg_src_list.lo str_list.lo void_list.lo ../libbb/libbb.la
generating symbol list for `libopkg.la'
i386-linux-uclibc-nm .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o ../libbb/.libs/libbb.a | | /opt/chjdoc/fos/trunk/staging_dir/host/bin/sed 's/.* ' | sort | uniq > .libs/libopkg.exp
../libtool: eval: line 4350: syntax error near unexpected token `|'
../libtool: eval: line 4350: `i386-linux-uclibc-nm .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o ../libbb/.libs/libbb.a | | /opt/chjdoc/fos/trunk/staging_dir/host/bin/sed 's/.*
' | sort | uniq > .libs/libopkg.exp'
make[3]: * [libopkg.la] Error 1
make[3]: Leaving directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libopkg'
make[2]:
* [all] Error 2
make[2]: Leaving directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/libopkg'
make[1]: * [all-recursive] Error 1
make[1]: Leaving directory `/opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564'
make:
* /opt/chjdoc/fos/trunk/build_dir/i386/opkg-4564/.built Error 2
make: Leaving directory `/opt/chjdoc/fos/trunk/package/opkg'
chj@linux-xzlr:trunk\>

my computer's compile environment is:

chj@linux-xzlr:trunk\> gcc --version
gcc (SUSE Linux) 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

chj@linux-xzlr:trunk\> uname -a
Linux linux-xzlr 2.6.27.4-xen #1 SMP Mon Oct 27 23:56:16 CST 2008 i686 i686 i386 GNU/Linux
chj@linux-xzlr:trunk\>

Attachments (1)

opkg_compile_error.output (4.4 KB) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by anonymous

comment:1 Changed 9 years ago by anonymous

Try with:

$ make package/opkg/{clean,compile}

comment:2 Changed 9 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

most likely caused by disabling c++

comment:3 Changed 9 years ago by acoul <alex at ozo.com>

this bug is still with us using gcc-4.4.0

mips-openwrt-linux-uclibc-nm  .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o .libs/active_list.o  ../libbb/.libs/libbb.a |  | /extra/openwrt/ar71xx/trunk/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/libopkg.exp
../libtool: eval: line 4350: syntax error near unexpected token `|'
../libtool: eval: line 4350: `mips-openwrt-linux-uclibc-nm  .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o .libs/active_list.o  ../libbb/.libs/libbb.a |  | /extra/openwrt/ar71xx/trunk/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/libopkg.exp'
make[5]: *** [libopkg.la] Error 1
make[5]: Leaving directory `/extra/openwrt/ar71xx/trunk/build_dir/target-mips_uClibc-0.9.30.1/opkg-5085/libopkg'
make[4]: *** [all] Error 2

comment:4 Changed 9 years ago by acoul <alex at ozo.com>

r16345 fixes (for me) this

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.