Modify

Opened 9 years ago

Closed 9 years ago

#4375 closed defect (duplicate)

Can't build PS3 due to powerpc-gcc SEGFAULT

Reported by: muelli Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Please see the following excerpt from the build log:

make[7]: Leaving directory `/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/gcc'
/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/./gcc/xgcc -B/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/./gcc/ -B/home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/bin/ -B/home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/lib/ -isystem /home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/include -isystem /home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/sys-include -O2 -g -Os -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -isystem ./include -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -DGCC_FLOAT_NOT_NEEDED -I. -I. -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/. -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/../include -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/../libcpp/include -DFINE_GRAINED_LIBRARIES -DL_addsub_df -c dp-bit.c -o libgcc/./_addsub_df.o
<built-in>:0: note: someone does not honour COPTS correctly, passed 0 times
dp-bit.c: In function '_fpadd_parts':
dp-bit.c:621: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://dev.openwrt.org/> for instructions.
make[6]: * [libgcc/./_addsub_df.o] Error 1
make[6]: Leaving directory `/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/gcc'
make[5]:
* [stmp-multilib] Error 2
make[5]: Leaving directory `/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/gcc'

Please tell me if I can provide any further information.

Attachments (1)

openwrt.log (52.3 KB) - added by muelli 9 years ago.
PS3 build log gcc crashing

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by muelli

PS3 build log gcc crashing

comment:1 Changed 9 years ago by anonymous

Oh, sorry, here comes the formatted error, which looks like ticket:4272

make[7]: `crtsavres.o' is up to date.
make[7]: Leaving directory `/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/gcc'
/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/./gcc/xgcc -B/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/./gcc/ -B/home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/bin/ -B/home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/lib/ -isystem /home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/include -isystem /home/muelli/svn/openwrt/staging_dir/toolchain-powerpc_gcc4.1.2/powerpc-linux-uclibc/sys-include -O2  -g -Os -DIN_GCC -DCROSS_COMPILE   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -I. -I. -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/. -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/../include -I/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2/gcc/../libcpp/include  -DFINE_GRAINED_LIBRARIES -DL_addsub_df -c dp-bit.c -o libgcc/./_addsub_df.o
<built-in>:0: note: someone does not honour COPTS correctly, passed 0 times
dp-bit.c: In function '_fpadd_parts':
dp-bit.c:621: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://dev.openwrt.org/> for instructions.
make[6]: *** [libgcc/./_addsub_df.o] Error 1
make[6]: Leaving directory `/home/muelli/svn/openwrt/build_dir/toolchain-powerpc_gcc4.1.2/gcc-4.1.2-initial/gcc'
make[5]: *** [stmp-multilib] Error 2

comment:2 Changed 9 years ago by juhosg

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4272.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.