Modify

Opened 9 years ago

Closed 9 years ago

#4357 closed defect (worksforme)

can't build x86 target due to include/net/ieee80211.h:251: error: nested redefinition of 'enum ieee80211_statuscode

Reported by: muelli Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: wlan, ipw2100 Cc:

Description

Aloha,

I tried to build OpenWRT for x86 on my Fedora 9 - x86_64 by simply doing a svn co, make menuconfig (leaving nearly everything as their defaults), make.

This, however, fails badly with the following errors:

In file included from /dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-12-11/drivers/net/wireless/ipw2x00/ipw2100.h:42,
                 from /dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-12-11/drivers/net/wireless/ipw2x00/ipw2100.c:168:
include/net/ieee80211.h:251: error: nested redefinition of 'enum ieee80211_statuscode'
include/net/ieee80211.h:251: error: redeclaration of 'enum ieee80211_statuscode'
include/net/ieee80211.h:252: error: redeclaration of enumerator 'WLAN_STATUS_SUCCESS'
/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-12-11/include/linux/ieee80211.h:880: error: previous definition of 'WLAN_STATUS_SUCCESS' was here
include/net/ieee80211.h:253: error: redeclaration of enumerator 'WLAN_STATUS_UNSPECIFIED_FAILURE'
/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-12-11/include/linux/ieee80211.h:881: error: previous definition of 'WLAN_STATUS_UNSPECIFIED_FAILURE' was here
.....
/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-12-11/drivers/
net/wireless/ipw2x00/ipw2100.c:7743: error: 'struct ieee80211_device' has no mem
ber named 'crypt_info'
make[8]: *** [/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-
12-11/drivers/net/wireless/ipw2x00/ipw2100.o] Error 1
make[7]: *** [/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-
12-11/drivers/net/wireless/ipw2x00] Error 2
make[6]: *** [/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wireless-2008-
12-11/drivers/net/wireless] Error 2
make[5]: *** [_module_/dev/shm/openwrt/build_dir/linux-x86_generic/compat-wirele
ss-2008-12-11] Error 2
make[5]: Leaving directory `/dev/shm/openwrt/build_dir/linux-x86_generic/linux-2
.6.27.8'
make[4]: *** [modules] Error 2
make[4]: Leaving directory `/dev/shm/openwrt/build_dir/linux-x86_generic/compat-
wireless-2008-12-11'

I'll attach the full build log.

It works if I disable ipw2100 within menuconfig.

Attachments (1)

openfail.log.bz2 (31.7 KB) - added by muelli 9 years ago.
build log

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by muelli

build log

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the build error here.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.