Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4343 closed defect (worksforme)

make menuconfig fails on Debian Lenny

Reported by: volker@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

make menuconfig fails on Debian Lenny

volker@eos trunk > make menuconfig V=99
Checking 'working-make'... ok.
Checking 'case-sensitive-fs'... ok.
Checking 'working-gcc'... ok.
Checking 'working-g++'... ok.
Checking 'ncurses'... ok.
Checking 'zlib'... ok.
Checking 'gawk'... ok.
Checking 'bison'... ok.
Checking 'flex'... ok.
Checking 'unzip'... ok.
Checking 'bzip2'... ok.
Checking 'patch'... ok.
Checking 'perl'... ok.
Checking 'python'... ok.
Checking 'wget'... ok.
Checking 'gnutar'... ok.
Checking 'svn'... ok.
Checking 'autoconf'... ok.
Checking 'gnu-find'... ok.
Checking 'getopt-extended'... ok.
Checking 'non-root'... ok.
make: *** scripts/config: No such file or directory.  Stop.
make: *** [scripts/config/mconf] Fehler 2

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug here, make sure you did not make any local change that could lead to this error.

comment:2 Changed 9 years ago by volker@…

Bug cannot reproduced if environment variable BASH_ENV is empty

volker@eos 8.09 > BASH_ENV='' make menuconfig
#
# using defaults found in .config
#

Your configuration changes were NOT saved.

as compared to

volker@eos 8.09 > BASH_ENV='/home/volker/.bashrc' make menuconfig
make -s -C scripts/config all: build failed. Please re-run make with V=99 to see what's going on
make: *** [scripts/config/mconf] Error 1

Thanks for your help.

comment:3 Changed 9 years ago by exobyte

This happened to me. The problem was CC and LD were set wrong. I had to delete a few executables and objects, but then it worked, again.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.