Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4296 closed defect (fixed)

ar71xx: eth: strange "spurious" interrupts

Reported by: suro@… Owned by: juhosg
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: routerboard, ar71xx Cc:

Description

Hi there!

I have a Mikrotik RouterBoard 450 running Kamikaze.
Most of the time the board works OK.
But as soon as high traffic amount (ex. with: hping --udp --flood) reaches any of the eth interfaces, the system goes nuts.
That interface's IRQ starts receiving very high amount of interrupts (half a million a second). ksoftirqd process consumes 100% CPU load. The console becomes quite unresponsive (but not totally frozen), but I can still ping the system on the other interface.

And the most interesting part of the problem is: it doesn't stop when I stop sending traffic.
As a result I see the system show 500000 interrupts/s on eth0 interface while the interface receives NO TRAFFIC AT ALL.

I have checked with r13167, r13426 and r13512

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by juhosg

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:2 follow-up: Changed 9 years ago by juhosg

Should be fixed with [13525]. Once you stop the flood ping, it should work normally again.

comment:3 in reply to: ↑ 2 Changed 9 years ago by anonymous

Replying to juhosg:

Should be fixed with [13525]. Once you stop the flood ping, it should work normally again.

Thanks!

I'll check ASAP and let you know!

comment:4 Changed 9 years ago by suro@…

Yup! It works!

I didn't have enough time to test it thoroughly, but looks like it's solved.

Thank You very much!

comment:5 Changed 9 years ago by juhosg

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.