Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#424 closed defect (fixed)

kernel panic after starting wpa_supplicant (Kernel 2.6.16 on WGT634U)

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description (last modified by nbd)

ctrl_interface_group=0pplicant -ieth1 -Dmadwifi -c /config/wpa_supplicant.conf -d
eapol_version=1
ap_scan=1
Priority group 2
   id=0 ssid='EgonNet'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
ioctl[SIOCSIWMODE]: Invalid argument
Could not configure driver to use managed mode
SIOCGIWRANGE: WE(compiled)=19 WE(source)=13 enc_capa=0x0
  capabilities: key_mgmt 0x0 enc 0x3
Own MAC address: 00:09:5b:f7:2a:cf
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
wpa_driver_madwifi_set_countermeasures: enabled=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface ath0
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
Wireless event: cmd=0x8b19 len=8
Received 0 bytes of scan results (0 BSSes)
Scan results: 0
Selecting BSS from priority group 2
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b1a len=8
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface ath0
State: SCANNING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=0
wpa_driver_madwifi_set_countermeasures: enabled=0
No keys have been configured - skip key clearing
ioctl[IEEE80211_IOCTL_SETOPTIE]: Invalid argument
wpa_driver_madwifi_deinit: failed to clear WPA IE
ioctl[SIOCSIWAP]: Invalid argument
Cancelling scan request
root@OpenWrt:/# Data bus error, epc == c00e373c, ra == c00e1dd4
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000dc00 c0088000 00008000
$ 4   : 81c70000 81c703f0 81c703f0 81c702b0
$ 8   : 000000c0 00000000 80259588 81156000
$12   : 00000000 00000000 00000014 00000115
$16   : 80240a04 81c70000 81c703f0 813cc000
$20   : 00000000 813cc398 80219da0 00000000
$24   : 00000002 c010beb0
$28   : 80218000 80219cf8 81c703f0 c00e1dd4
Hi    : 000003c5
Lo    : 1eb3f600
epc   : c00e373c     Tainted: P
ra    : c00e1dd4 Status: 1000dc03    KERNEL EXL IE
Cause : 0000001c
PrId  : 00029007
Modules linked in: ehci_hcd uhci_hcd usb_storage sd_mod scsi_mod usblp ohci_hcd usbcore ip_conntrack_tftp ip_nat_pptp ip_conntrack_pptp ip_conntrack_amanda vfat fat te
Process swapper (pid: 0, threadinfo=80218000, task=8021a000)
Stack : 00000000 c00e1524 813cc260 813cc000 81c70000 813cc398 80240a04 81c70000
        81c70000 c00e1dd4 813cc260 813cc000 80218000 80219d50 00000010 c0105c54
        1000dc03 000178ff 00000237 00000000 00008000 c0105c70 8026038c 81bd6c24
        80240a04 00000000 813cc260 813cc000 81c70000 813cc398 813cc260 00000000
        00000010 c010c06c 80219de0 00000006 8000f0a8 00000001 80219da8 00100100
        ...
Call Trace: [<c00e1524>]  [<80240a04>]  [<c00e1dd4>]  [<c0105c54>]  [<c0105c70>]  [<80240a04>]  [<c010c06c>]  [<8000f0a8>]  [<80048e84>]  [<80033060>]  [<80240a04>]

Code: 8e220014  34038000  00431021 <8c421860> 30420002  14400018  00008025  3c02c00e  24423670
Kernel panic - not syncing: Aiee, killing interrupt handler!
 <0>Rebooting in 3 seconds..Please stand by while rebooting the system...

Attachments (0)

Change History (4)

comment:1 Changed 12 years ago by dacb

what revision is this? I am unable to duplicate it with 3535 which is 2.6.16 .

comment:2 Changed 12 years ago by anonymous

can't reproduce it at this time, too. got another problem #463

comment:3 Changed 12 years ago by nbd

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.