Opened 9 years ago

Closed 9 years ago

#4212 closed defect (fixed)

coreutils compilation error

Reported by: anonymous Owned by: florian
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:


Can't compile coreutils-6.9

packages revision: 13216

make[6]: Entering directory `/home/phasma/download/work/kamikaze/build_dir/mipsel/coreutils-6.9/src'
mipsel-linux-uclibc-gcc -std=gnu99  -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts   -L/home/phasma/download/work/kamikaze/staging_dir/toolchain-mipsel_gcc4.1.2/lib -L/home/phasma/download/work/kamikaze/staging_dir/mipsel/usr/lib -L/home/phasma/download/work/kamikaze/staging_dir/mipsel/lib  -Wl,--as-needed -o chgrp chgrp.o chown-core.o ../lib/libcoreutils.a  ../lib/libcoreutils.a 
../lib/libcoreutils.a(close-stream.o): In function `close_stream':
close-stream.c:(.text+0x24): warning: This version of __fpending returns bytes remaining in buffer for both narrow and wide streams.  glibc's version returns wide chars in buffer for the wide stream case.
chown-core.o: In function `chown_files':
chown-core.c:(.text+0x404): undefined reference to `fstatat'
chown-core.c:(.text+0x6ac): undefined reference to `openat64'
chown-core.c:(.text+0x700): undefined reference to `openat64'
../lib/libcoreutils.a(fts.o): In function `diropen':
fts.c:(.text+0x168): undefined reference to `openat64'
../lib/libcoreutils.a(fts.o): In function `fts_stat':
fts.c:(.text+0x434): undefined reference to `fstatat'
../lib/libcoreutils.a(fts.o): In function `fts_build':
fts.c:(.text+0x9e8): undefined reference to `openat64'
fts.c:(.text+0xa04): undefined reference to `fdopendir'
../lib/libcoreutils.a(chdir-long.o): In function `cdb_advance_fd':
chdir-long.c:(.text+0xdc): undefined reference to `openat64'
../lib/libcoreutils.a(getcwd.o): In function `rpl_getcwd':
getcwd.c:(.text+0x13c): undefined reference to `openat64'
getcwd.c:(.text+0x1a4): undefined reference to `fdopendir'
getcwd.c:(.text+0x2a0): undefined reference to `fstatat'
getcwd.c:(.text+0x2b8): undefined reference to `fstatat'
getcwd.c:(.text+0x3e8): undefined reference to `openat64'
collect2: ld returned 1 exit status
make[6]: *** [chgrp] Error 1
make[6]: Leaving directory `/home/phasma/download/work/kamikaze/build_dir/mipsel/coreutils-6.9/src'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/phasma/download/work/kamikaze/build_dir/mipsel/coreutils-6.9/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/phasma/download/work/kamikaze/build_dir/mipsel/coreutils-6.9'
make[3]: *** [/home/phasma/download/work/kamikaze/build_dir/mipsel/coreutils-6.9/.built] Error 2
make[3]: Leaving directory `/home/phasma/download/work/packages/utils/coreutils'
make[2]: *** [package/coreutils/compile] Error 2
make[2]: Leaving directory `/home/phasma/download/work/kamikaze'
make[1]: *** [/home/phasma/download/work/kamikaze/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/phasma/download/work/kamikaze'
make: *** [world] Ошибка 2

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

Confirmed, will fix that.

comment:2 Changed 9 years ago by seniorr@…

The same or a very similar problem affects packages/utils/tar, fwiw.

comment:3 Changed 9 years ago by jasong@…

I just received this error also for tar (whether separate or in coreutils) and googling so far isn't turning up much. These are xattr references, and apparently are found (at least) in e2fsprogs.

I don't believe there should be a dependency on e2fsprogs. Perhaps there are some headers missing that coreutils and tar should point to (or are just missing in those packages)?

comment:4 Changed 9 years ago by jasong@…

see here for glibc references to these.

Just to say I tried, I tried coreutils-6.12 with the same results. I am going to check my ubuntu package for patches or include/config directives to point to the correct sources.

Hope some of this helps at all.

comment:5 Changed 9 years ago by M4

After some researches, it seems that doesn't have openat64, fdopendir and fstatat symbols (objdump -T When you look headers (sys/stat.h for example), you have the definition of fstatat between ifdef. So, probably a config problem.


Do you have some ideas about it ?

comment:6 Changed 9 years ago by crick <mail@…>

The problem in the patch "toolchain/uClibc/patches/160-add_openat_and_friends.patch". Without it, everything is going well.

comment:7 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [13817].

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.