Modify

Opened 9 years ago

Closed 4 years ago

Last modified 4 years ago

#4182 closed defect (obsolete)

iwconfig on prism0 crashes WRT54GL when monitor is 1

Reported by: jeromepoulin@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: wlc monitor prism prism0 iwconfig reboot Cc:

Description

When using this sequence of command, my router reboots:
wlc monitor 1
tcpdump -i prism0 -vn
No Data received
wlc ap 0
tcpdump -i prism0 -vn
Now I receive data
iwconfig
Poof, freeze+reboot

It starts listing all the interfaces, including wl0, then freeze when about to display prism0.

Attachments (1)

050-prism.patch (484 bytes) - added by Chris Martin <chris@…> 7 years ago.
Patch to compile wireless tools with IW_RESTRIC_ENUM

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by florian

How about using /etc/config/wireless to properly set the interface to monitor and then get it to its normal mode ?

comment:2 follow-up: Changed 9 years ago by cpanti@…

It seems that nomatter what I'm trying to do with prism0 my WRT54GL is rebooting.

comment:3 in reply to: ↑ 2 Changed 9 years ago by lars.walter@…

Replying to cpanti@gmail.com:

It seems that nomatter what I'm trying to do with prism0 my WRT54GL is rebooting.

I am encountering the same issues on my router (wrt54gl v1.1, kamikaze 8.09) but couldn't find a solution on the net. Sounds like it worked in the past and stopped working after a hard- or software-change of the router and/or kamikaze. I would appreciate a fix for this. ;) Thanks!

comment:4 Changed 9 years ago by anonymous

Same thing happens with Buffalo WHR-G125 + kamikaze 8.09.
wlc up; wlc monitor 1; iwconfig prism0; => reboot

comment:5 follow-up: Changed 8 years ago by anonymous

Same with WRT54GL + Kamikaze 8.09 (and 8.09.1). Is it solved yet?

comment:6 in reply to: ↑ 5 Changed 8 years ago by info@…

Replying to anonymous:

Same with WRT54GL + Kamikaze 8.09 (and 8.09.1). Is it solved yet?

Same Problem with WRT54GL V1.1 and Kamikaze 8.09.1. So it doesn't seem to be solved...

comment:7 Changed 8 years ago by anonymous

I have exactly the same problem on a wl500gp with 8.09.1.

This leads do a reboot:
wlc down; wlc up; wlc monitor 1; iwconfig

Same with "iwconfig wl0 monitor; iwconfig"

comment:8 Changed 8 years ago by razgriz

Hi Guy,
i have the same problem.. :(

comment:9 Changed 8 years ago by aperez@…

Same problem... Any step on this?

comment:10 Changed 7 years ago by anonymous

same problem here on Buffalo WHR-G125

comment:11 Changed 7 years ago by m@…

This is still a problem in Backfire, using a WRT54GL. I'd be glad to provide any necessary debugging info if the developers tell me what they need.

For some reason I seem to need to add lots of extra text here due to filtering. How frustrating, maybe you guys could use a captcha or something instead?

comment:12 Changed 7 years ago by chris@…

I have just been doing a bit of work in this area
The problem is not with the "wlcomat" module but with the broadcom wl driver
The Prism interface is not well protected against invalid/unsupported IOCTLs
If the wlcompat module is not loaded the same problem persists.

This in turn means that iwconfig and iwlist will have to be patched to avoid iterating over the PRISM0 interface

comment:13 Changed 7 years ago by chris@…

If IW_RESTRIC_ENUM is defined in iwlib.c, then the wireless tools will use /proc/net/wireless to iterate the devices rather than /proc/net/dev with the result that it will not enumerate the PRISM interface

comment:14 Changed 7 years ago by Chris Martin <chris@…>

I have attached a patch that will build wireless tools with IW_RESTRIC_ENUM defined.

Simply copy the patch file in to the directory /package/wireless-tools/patches and rebuild. NOTE: this patch was make on 8.09 with wireless tools .29

Changed 7 years ago by Chris Martin <chris@…>

Patch to compile wireless tools with IW_RESTRIC_ENUM

comment:15 Changed 7 years ago by defaste

Patch works partially.
My WRT54GL doesn't reboot anymore if i type

ifconfig wl0 down
wlc monitor 1
iwconfig

But airmon-ng doesn't work.

airmon-ng start wl0
Interface       Chipset         Driver
wl0             Unknown         Unknown (MONITOR MODE NOT SUPPORTED)

comment:16 Changed 7 years ago by defaste

Patch compiles in last backfire release (10.03.1-rc4).
Airmon-ng still doesn't work.

comment:17 Changed 4 years ago by tripolar

  • Resolution set to obsolete
  • Status changed from new to closed
  • Version set to Trunk

please try latest trunk a reopen a new bug report if the problem still exists.

Last edited 4 years ago by tripolar (previous) (diff)

comment:18 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.