Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4169 closed defect (duplicate)

2.6.27 for brcm47xx

Reported by: candrews@… Owned by: developers
Priority: normal Milestone: Kamikaze 8.09
Component: kernel Version:
Keywords: b43 2.6.27 brcm47xx Cc:

Description

The WL-500gp's wireless stops working after a while with the 2.6.25 kernel presently in trunk. Theory has it that an upgrade to kernel 2.6.27 with the latest mac80211 and compat-wireless may fix that.

There is some talk of 2.6.27 on brcm47xx in http://forum.openwrt.org/viewtopic.php?id=17307

Thanks!

Attachments (1)

0010-add-initial-2.6.27-support-for-brcm47xx-target.patch (114.0 KB) - added by Hauke <hauke@…> 9 years ago.
[PATCH] add initial 2.6.27 support for brcm47xx target

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by candrews@…

Bartman007 pointed out me to sn9's patches that are a work in progress: http://downloads.openwrt.org/people/agb/brcm47xx-2.6.27/

comment:2 Changed 9 years ago by elmargol@…

I have the same problem.

*subscribing to bug*

comment:3 Changed 9 years ago by candrews@…

On the forums at http://forum.openwrt.org/viewtopic.php?pid=77576 I discovered that advance38 has created a newer patch. It's available at http://dongsupark.de/wiki/doku.php?id=linux:openwrt I plan to try it out soon - I hope others do too.

comment:4 Changed 9 years ago by jeroen@…

I apparently also need 2.6.27 due to #4262, thus subbing to this bug.
I'll try the patch this evening when I am home again (fixing a box 20km away remotely is not happening unfortunately and I have the wrt so that that is one component I just can rely on that it keeps working, which it generally does ;)

comment:5 Changed 9 years ago by advance38@…

Try http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff with OpenWRT r13514. Maybe you can compile OpenWRT brcm47xx with kernel 2.6.27.4. But I'm not sure yet if wlan works with this patch.

comment:6 Changed 9 years ago by jeroen@…

I've now got a r13621 with http://dongsupark.de/openwrt/kamikaze-r13514-b43ssb-2.6.27.diff applied (which applies cleanly btw), but nevertheless even though this is a nice spanky new 2.6.27.4 it seems to still run out of memory or something else when doing a high-speed transfer (both over IPv4 or IPv6) :(

I'll try to enable netconsole later so that I can get the debug output if any.

comment:7 Changed 9 years ago by jeroen@…

Oh and the wireless indeed does not work yet (that is on my WRT54GS). Interface is detected by the kernel, all the needed interfaces are there also in userspace, but it does not work, thus that requires more work too (but as I don't need the wireless really, not a big issue for me).

comment:8 follow-up: Changed 9 years ago by loswillios

might be worth a try to directly go to 2.6.28, now that the generic patches are in openwrt

comment:9 in reply to: ↑ 8 Changed 9 years ago by anonymous

Replying to loswillios:

might be worth a try to directly go to 2.6.28, now that the generic patches are in openwrt

2.6.28 might be in generic , but it has not been fixed up yet for the brcm47xx target, thus unless I do some hacking myself, no 2.6.28 for this target yet.

(svn 13672 is the one I just tried btw)

comment:10 Changed 9 years ago by jeroen@…

ehmm oops, that was me ;)

Changed 9 years ago by Hauke <hauke@…>

[PATCH] add initial 2.6.27 support for brcm47xx target

comment:11 Changed 9 years ago by Hauke <hauke@…>

The attached patch is a cleaned up version of the last patch form jeroen posted here.

comment:12 Changed 9 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

obsoleted by #4395

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.