Modify

Opened 9 years ago

Last modified 3 years ago

#4129 reopened defect

gpiommc no longer working with 2.6.26.5 kernel

Reported by: eikaf Owned by: juhosg
Priority: normal Milestone: Kamikaze 8.09
Component: other Version:
Keywords: gpiommc Cc:

Description (last modified by juhosg)

My hardware is atheros(Fonera 2200). With old firmware the kmod-mmc driver with dependacies compiled from trunk used to work.I have tried to compile from trunk again with rev 13036, but after flashingo it to fonera it gives me this error.

gpio-mmc: Failed to request mmc_spi module.
mmc_spi spi32766.0: ASSUMING 3.2-3.4 V slot power
mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
gpio-mmc: MMC-Card "default" attached to GPIO pins di=7, do=2, clk=6, cs=14
mmc_spi spi32766.0: can't change chip-select polarity
mmc0: error -22 whilst initialising SDIO card

Attachments (0)

Change History (21)

comment:1 Changed 9 years ago by stephanv6

Can confirm that, does not work on the atheros build.
How to fix that ?

comment:2 Changed 9 years ago by 7M

I confirm too.

comment:3 Changed 9 years ago by juhosg

  • Milestone changed from Kamikaze 7.09 to Kamikaze 8.09

comment:4 Changed 9 years ago by juhosg

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:5 Changed 9 years ago by juhosg

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [13139], [13140].

comment:6 Changed 9 years ago by eikaf

still not working here. Same error:
gpio-mmc: Failed to request mmc_spi module.
mmc_spi spi32766.0: ASSUMING 3.2-3.4 V slot power
mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
gpio-mmc: MMC-Card "default" attached to GPIO pins di=7, do=2, clk=6, cs=14
mmc_spi spi32766.0: can't change chip-select polarity
mmc0: error -22 whilst initialising SDIO card

sorry 'bout this, did you tested that?

comment:7 Changed 9 years ago by juhosg

Of course. Did you run 'make target/linux/clean world'?

...
wlan: trunk
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 2008-10-02 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, DFS)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_pci: trunk
gpio-mmc: Failed to request mmc_spi module.
mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
gpio-mmc: MMC-Card "default" attached to GPIO pins di=2, do=10, clk=3, cs=1
mmc_spi spi32766.0: can't change chip-select polarity
mmc0: new SD card on SPI
mmcblk0: mmc0:0000 SA01G 995328KiB
 mmcblk0: p1



BusyBox v1.11.2 (2008-11-05 11:24:55 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r13141) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@OpenWrt:/# uname -a
Linux OpenWrt 2.6.26.7 #8 Sat Nov 8 19:02:12 CET 2008 armv5teb unknown
root@OpenWrt:/# cat /proc/cpuinfo
Processor       : XScale-IXP42x Family rev 2 (v5b)
BogoMIPS        : 532.48
Features        : swp half fastmult edsp
CPU implementer : 0x69
CPU architecture: 5TE
CPU variant     : 0x0
CPU part        : 0x41c
CPU revision    : 2
Cache type      : undefined 5
Cache clean     : undefined 5
Cache lockdown  : undefined 5
Cache format    : Harvard
I size          : 32768
I assoc         : 32
I line length   : 32
I sets          : 32
D size          : 32768
D assoc         : 32
D line length   : 32
D sets          : 32

Hardware        : ADI Engineering Pronghorn
Revision        : 0000
Serial          : 0000000000000000
root@OpenWrt:/#

comment:8 Changed 9 years ago by eikaf

actually i did clean trunk before compiling, but as i can see, u tested it on fonera 2100, my fonera is a 2200 i don't know if it depends on it.I'll test again tomorrow.

comment:9 Changed 9 years ago by eikaf

tested again and it gives me always the same error.

comment:10 Changed 9 years ago by eikaf

i don't know why now it doesn't give me the error but it doesn't give me mmc output.
this is my dmesg

http://pastebin.com/m590db1e3

comment:11 Changed 9 years ago by eikaf

compiled again from trunk and the error has come back...i was missing it :D

comment:12 Changed 9 years ago by 7M

I confirm: the driver doesn't work on Fonera 2200.
As the 2100 uses a different gpio mapping, maybe some other kernel part owns one or more of the gpio
numbered 7, 2, 6. Is that the case?

comment:13 Changed 9 years ago by juhosg

Well, i have tried it on an ixp425 based board originally, and it worked properly, even with 3 GPIO lines (chip-select line was connected to ground).

In the last few days, i tried to modify a fon2200 board, unfortunately i have killed it. Then i tried it on a WBD-500 (it is an ar2315 based board also).
First I got the same error, I spent two days trying to fix it without success. This morning i have checked the wires, and i saw that the DO and CLK lines was swapped.
Now it works without errors even if i use 3 or 4 GPIO lines.

I guess it should be a hardware problem.

ath_ahb: trunk
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_ahb: wifi0: Atheros 2315 WiSoC: mem=0xb0000000, irq=3
gpio-mmc: Failed to request mmc_spi module.
mmc_spi spi32766.0: SD/MMC host mmc0, no DMA, no WP, no poweroff
gpio-mmc: MMC-Card "default" attached to GPIO pins di=0, do=3, clk=1, cs=4
mmc_spi spi32766.0: can't change chip-select polarity
mmc0: new SD card on SPI
mmcblk0: mmc0:0000 SA01G 995328KiB
 mmcblk0: p1



BusyBox v1.11.3 (2008-11-12 16:16:51 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (bleeding edge, r13191) -------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@OpenWrt:/# uname -a
Linux OpenWrt 2.6.26.7 #1 Wed Nov 12 16:37:33 CET 2008 mips unknown
root@OpenWrt:/# cat /proc/cpuinfo
system type             : Atheros AR2315
processor               : 0
cpu model               : MIPS 4KEc V6.4
BogoMIPS                : 183.50
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : no
ASEs implemented        :
shadow register sets    : 1
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

root@OpenWrt:/#

comment:14 Changed 9 years ago by 7M

I don't agree: on the same machine, the same wiring scheme works well if I use kamikaze trunk
r11770. I think the problem arose when the package was merged into the kernel. There was already some piece of code there which generated conflict not with the mmc driver code, but with the particular gpio numbers used on fonera 2200 (as the drives was well tested on other architectures).
If this is the case, the only chance is to disable that piece of code.
I guessed it was the kernel use of leds; but disabling it (make kernel_menuconfig ...) does't solve the problem...

Any other ideas?

comment:15 Changed 9 years ago by metyl

i can confirm this is a buf, i have two fon2200 with mmc hack supposed to run on legend firmware. there is problem running openwrt. In legend fimware it was fixed removing code for reset button (GPIO 6) handling, can anyone confirm this is the same issue ?

comment:16 Changed 9 years ago by metyl

the configuration used from legend mmc hack is using power led, WLAN led, reset button

add_device "default" 7 2 6 14 0

this 14 its a dummy gpio

the gpio pins was like:

http://fon.testbox.dk/packages/mmc/mmcmodinfo/2200mmc1.jpg
http://fon.testbox.dk/packages/mmc/mmcmodinfo/2200mmc2.jpg

The gpio5 its not need, makes your device reset

comment:17 Changed 9 years ago by anonymous

or can be this issue based on using dummy pin 14 as CHIP SELECT for mmc card ?

comment:18 Changed 9 years ago by eikaf

it's not dued to the gpio pin 14 because with previous build it does work, the problem appears when you compile with new kernels.

comment:19 Changed 9 years ago by eikaf

will be this ever fixed?

comment:20 Changed 3 years ago by valentt

Probably it was fixed because I had it running a month ago with trunk version of OpenWrt but with todays trunk version I get this error again... so not sure what is going on. Is anybody else having issues?

comment:21 Changed 3 years ago by valentt

  • Resolution fixed deleted
  • Status changed from closed to reopened

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.