Modify

Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#4088 closed defect (fixed)

Cannot associate atheros interface when signal is lower that -50db

Reported by: strzol@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: madwifi, signal level Cc:

Description

I have a x86 router with 5 atheros interfaces (Winstron CM9) working with kamikaze 7.09.

When i installed revision r12926 build with openwrt madwifi branch only one interface associates (it has signal level -45db). All the others that have signal level about -60db cannot associate with the aps. All cards are in station mode.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by cr

Is this problem similar to Ticket #3873?

comment:2 Changed 9 years ago by strzol@…

I haven't tried the reverse scenario (on the other side are atheros interfaces in ap mode on kamikaze 7.09 routers).

Maybe is the same. I think (thanks acinonyx from AWMN) that has something to do with the TPC option of the madwifi driver.

I will prepare a new svn build with madwifi compiled with TPC disabled and I will report.

If it is possible I will try also to reverse a link (the other side sta, the problematic side ap).

comment:3 Changed 9 years ago by strzol@…

After testing a new image compiled with TPC disabled for madwifi, I can confirm that this was the issue. I managed to have association on all interfaces.

So the problem is when the madwifi package is compiled with TPC enabled.

comment:4 Changed 8 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in newer versions

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.