Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#403 closed defect (fixed)

syslog-ng can't find libl (trunk r3472)

Reported by: tristan@… Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: 2.0
Keywords: Cc:

Description

Having trouble building syslog-ng. Previously I couldn't find libol, but that's since been fixed. Now I can't find libl (flex?)

/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src -I.   -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include/libol  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17
/src -D_GNU_SOURCE -c `test -f 'afremctrl.c' || echo '/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src/'`afremctrl.c
afremctrl.c: In function 'do_handle_afremctrl_dest':
afremctrl.c:58: warning: pointer targets in passing argument 1 of 'strcmp' differ in signedness
afremctrl.c:58: warning: pointer targets in passing argument 2 of 'strcmp' differ in signedness
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src -I.   -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include/libol  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17
/src -D_GNU_SOURCE -c `test -f 'nscache.c' || echo '/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src/'`nscache.c
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src -I.   -I/data2/openwrt/tris
tan/trunk/openwrt/staging_dir_mips/usr/include -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include/libol  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17
/src -D_GNU_SOURCE -c `test -f 'utils.c' || echo '/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src/'`utils.c
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src -I.   -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include/libol  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17
/src -D_GNU_SOURCE -c `test -f 'syslog-names.c' || echo '/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src/'`syslog-names.c
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src -I.   -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include -I/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/include/libol  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17
/src -D_GNU_SOURCE -c `test -f 'macros.c' || echo '/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src/'`macros.c
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/bin/mips-linux-uclibc-gcc  -g -O2 -Wall -I/data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17/src -D_GNU_SOURCE  -L/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/lib -L/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/usr/lib/libol -o syslog-ng  main.o sources.o center.o filters.o destinations.o log.o cfgfile.o cfg
-grammar.o cfg-lex.o affile.o afsocket.o afunix.o afinet.o afinter.o afuser.o afstreams.o afprogram.o afremctrl.o nscache.o utils.o syslog-names.o macros.o  -lnsl -lresolv  /data2/openwrt/tristan/trunk/openwrt/build_mips/libol-0.3.17/src/.libs/libol.a -lnsl -Wl,-Bstatic -ll -lwrap -Wl,-Bdynamic
/data2/openwrt/tristan/trunk/openwrt/staging_dir_mips/lib/gcc/mips-linux-uclibc/4.0.3/../../../../mips-linux-uclibc/bin/ld: cannot find -ll
collect2: ld returned 1 exit status
make[7]: *** [syslog-ng] Error 1
make[7]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src'
make[6]: *** [install-exec-recursive] Error 1
make[6]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/src'
make[5]: *** [install-exec-recursive] Error 1
make[5]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9'
make[4]: *** [/data2/openwrt/tristan/trunk/openwrt/build_mips/syslog-ng-1.6.9/.built] Error 2
make[4]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/package/syslog-ng'
make[3]: *** [compile] Error 2
make[3]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/package/syslog-ng'
make[2]: *** [syslog-ng-compile] Error 2
make[2]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/data2/openwrt/tristan/trunk/openwrt'
make: *** [world] Error 2

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by olli

  • Milestone set to 2.0
  • Version set to 2.0

comment:2 Changed 12 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to assigned

Can you try rebuilding both libol and syslog-ng and report whether the problem is solved or not?

comment:3 Changed 12 years ago by tristan@…

This is now working for me - thanks! (as are replies - for some reason I haven't been able to see this text box in Firefox over the last few days, but it seems to work in Safari...)

comment:4 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.