Modify

Opened 9 years ago

Closed 9 years ago

#3964 closed defect (wontfix)

kernel modules get not build

Reported by: michu-at-neophob-com Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

platform: bcm47xx, 2.6 Kernel
svn r12539, error:

those packages get's not build:

kmod-input-core
kmod-input-evdev

input-core.o and evdev.o gets build, however the packages not.

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by norbert

target/linux/brcm47xx/config-2.6.25 (r12761) defines:
CONFIG_INPUT=y
CONFIG_INPUT_EVDEV=y

target/linux/generic-2.6/config-2.6.25 (r12761) defines:
# CONFIG_INPUT is not set
CONFIG_INPUT_EVDEV=m

I belive its not a bug.

comment:2 Changed 9 years ago by norbert

After some test with bcm47xx and x86 (alix): I'am not sure.

At bcm47xx has OpenWRT .config
CONFIG_PACKAGE_kmod-input-core=m
CONFIG_PACKAGE_kmod-input-evdev=m

no packages build, build_dir/linux-brcm47xx/linux-2.6.25.17/.config contain:
CONFIG_INPUT=y
CONFIG_INPUT_EVDEV=y

At alix has OpenWRT .config
CONFIG_PACKAGE_kmod-input-core=m
CONFIG_PACKAGE_kmod-input-evdev=m

only kmod-input-evdev_2.6.25.17-x86-1_i386.ipk build; build_dir/linux-x86_generic/linux-2.6.25.17/.config contain:
CONFIG_INPUT=y
CONFIG_INPUT_EVDEV=m

Why is CONFIG_INPUT=y ?

comment:3 Changed 9 years ago by nico

  • Resolution set to wontfix
  • Status changed from new to closed

The input modules won't get built because input support is built-in the kernel on brcm-47xx.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.