Modify

Opened 9 years ago

Closed 7 years ago

#3960 closed defect (no_response)

Command 'set ssid' failed: -1

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone:
Component: other Version:
Keywords: Cc:

Description

Router WRT54GL v1.1
Openwrt kamikadze SVN r12377

root@OpenWrt:/etc/config# cat wireless
config wifi-device wl0

option type broadcom
option channel 5

# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface

option device wl0
option network lan
option mode ap
option ssid RM
option encryption psk
option key rxxxxxxxxxx

config wifi-iface

option device wl0
option network wifi_free
option mode ap
option ssid Free_Int
option encryption none

When uci commit wireless & & wifi I error:
Command 'set ssid' failed: -1

iwconfig wl0.1 is not assigned to the network Free_Int
iwconfig wl0 is not assigned to the network RM

As vice versa options
root@OpenWrt:/etc/config# cat wireless
config wifi-device wl0

option type broadcom
option channel 5

# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface

option device wl0
option network wifi_free
option mode ap
option ssid Free_Int
option encryption none

config wifi-iface

option device wl0
option network lan
option mode ap
option ssid RM
option encryption psk
option key rxxxxxxxxxx

It shows the correct attribution iwconfig network
root@OpenWrt:/etc/config# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth0.0 no wireless extensions.

eth0.1 no wireless extensions.

br-lan no wireless extensions.

wl0 IEEE 802.11-DS ESSID:"Free_Int"

Mode:Master Frequency:2.432 GHz Access Point: 00:1D:7E:BC:CD:C0
Bit Rate=54 Mb/s Tx-Power:32 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Link Quality:5 Signal level:0 Noise level:162
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

wl0.1 IEEE 802.11-DS ESSID:"RM"

Mode:Master Channel:5 Access Point: 02:1D:7E:BC:CD:C1
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off

ppp0 no wireless extensions.

logread but I have a message about error during the launching of the route

Jan 1 00:00:22 OpenWrt user.warn kernel: ip_conntrack_rtsp v0.01 loading
Jan 1 00:00:22 OpenWrt user.warn kernel: ip_nat_rtsp v0.01 loading
Jan 1 00:00:27 OpenWrt user.info kernel: device wl0.1 entered promiscuous mode
Jan 1 00:00:27 OpenWrt user.info kernel: br-lan: port 2(wl0.1) entering learning state
Jan 1 00:00:27 OpenWrt user.info kernel: br-lan: port 2(wl0.1) entering forwarding state
Jan 1 00:00:27 OpenWrt user.info kernel: br-lan: topology change detected, propagating
Jan 1 00:00:27 OpenWrt user.info : Command 'set ssid' failed: -1
Jan 1 00:00:28 OpenWrt user.info : Loading defaults
Jan 1 00:00:29 OpenWrt user.info : Loading synflood protection
Jan 1 00:00:30 OpenWrt user.info : Loading zones
Jan 1 00:00:31 OpenWrt user.info : Loading rules
Jan 1 00:00:31 OpenWrt user.info : Loading forwarding
Jan 1 00:00:31 OpenWrt user.info : Loading redirects
Jan 1 00:00:31 OpenWrt user.info : Loading includes

Attachments (0)

Change History (8)

comment:1 Changed 9 years ago by pieter@…

This comes from /lib/wifi/broadcom.sh when it does this:

        wlc stdin <<EOF
$vif_do_up
EOF

In $vif_do_up are commands to configure the virtual interfaces such as:

 vif 0 wsec 4 wpa_auth 64 wsec_restrict 1 eap_restrict 1 ssid FirstNet vif 1 wsec 4 wpa_auth 128 wsec_restrict 1 eap_restrict 0 ssid SecondNet

wlc seems to complain about applying the second ssid command to vif 1.

comment:2 Changed 9 years ago by pieter@…

Additional debug output from wlcompat-debug.

Oct  1 23:34:53 wl320gp user.warn kernel: dev: wl0 ioctl: 0x8946

Here I started "wlc stdin" manually.

Oct  1 23:34:53 wl320gp user.warn kernel: dev: wl0 ioctl: 0x89f0
Oct  1 23:34:53 wl320gp user.warn kernel:    cmd: 1 buf: 0x7fff7c0c len: 4
Oct  1 23:34:53 wl320gp user.warn kernel:    send: -> A045B42A
Oct  1 23:34:53 wl320gp user.warn kernel:    recv: -> 01000000
Oct  1 23:34:53 wl320gp user.warn kernel:    ret: 0

This is the command "vif 1" that was executed successfully.

Oct  1 23:35:15 wl320gp user.warn kernel: dev: wl0 ioctl: 0x89f0
Oct  1 23:35:15 wl320gp user.warn kernel:    cmd: 263 buf: 0x7fff7b5c len: 52
Oct  1 23:35:15 wl320gp user.warn kernel:    send: -> 62737363 66673A73 73696400 01000000 03000000 626C6100 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Oct  1 23:35:15 wl320gp user.warn kernel:    recv: -> 62737363 66673A73 73696400 01000000 03000000 626C6100 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Oct  1 23:35:15 wl320gp user.warn kernel:    ret: -22

This is the command "ssid bla" failing (in wlc itself a return code of -1 is returned).

comment:3 Changed 9 years ago by Fate <pieter@…>

Might be related to #3523

comment:4 Changed 9 years ago by anonymous

Same Problem with svn14037 on Buffalo WHR-HP-G54 (BCM5352). No wireless client can connect wl0.1. wl0 runs well in sta mode and wl0.1 in ap mode. Same config as in kamikaze 7.09.

wlc gives error message:
Command 'set mssid' failed: -1

ifconfig wl0.1:
wl0.1 Link encap:Ethernet HWaddr 00:xx:xx:xx:xx: 5F

iwconfig wl0.1:
wl0.1 Mode:Master Channel:10 Access Point: 02:xx:xx:xx:xx: 5C

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with [15200].

comment:6 Changed 8 years ago by zarkdav@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Same problem here. Using backfire 10.03 on WRT54GSv4.

# uci show wireless
wireless.wl0=wifi-device
wireless.wl0.type=broadcom
wireless.wl0.disabled=0
wireless.wl0.channel=7
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=wl0
wireless.@wifi-iface[0].ssid=Nakatomi_Plaza
wireless.@wifi-iface[0].network=wifi
wireless.@wifi-iface[0].mode=sta
wireless.@wifi-iface[0].encryption=psk
wireless.@wifi-iface[0].key=blah
wireless.@wifi-iface[1]=wifi-iface
wireless.@wifi-iface[1].device=wl0
wireless.@wifi-iface[1].ssid=Dulles_Airport
wireless.@wifi-iface[1].network=lan
wireless.@wifi-iface[1].mode=ap
wireless.@wifi-iface[1].encryption=none
# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth0.0    no wireless extensions.

eth0.1    no wireless extensions.

wl0       IEEE 802.11-DS  ESSID:"Nakatomi_Plaza"  
          Mode:Master  Frequency:2.442 GHz  Access Point: 8A:EA:35:96:39:50   
          Bit Rate=54 Mb/s   Tx-Power:32 dBm   
          RTS thr:off   Fragment thr:off
          Link Quality:5  Signal level:0  Noise level:164
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:0   Missed beacon:0

br-lan    no wireless extensions.

br-wifi   no wireless extensions.

wl0.1     IEEE 802.11-DS  ESSID:"Dulles_Airport"  
          Mode:Master  Channel:7  Access Point: 02:90:4C:5F:00:2B   
          Bit Rate=54 Mb/s   
          RTS thr:off   Fragment thr:off
# wifi
Command 'set ssid' failed: -1

Note: I am able to do multiple SSIDs on DD-WRT (although it's too limited for what I want to do, hence I try to do it with OpenWRT).

comment:7 Changed 7 years ago by nbd

  • Priority changed from normal to response-needed

Please try 10.03.1-rc4 or newer

comment:8 Changed 7 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.