Modify

Opened 12 years ago

Closed 10 years ago

Last modified 4 years ago

#389 closed defect (wontfix)

jpeg6b libtool created in wrong place compilation fails

Reported by: yaya Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: 2.0
Keywords: Cc:

Description


Attachments (0)

Change History (17)

comment:1 Changed 12 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 12 years ago by nico

Please provide at least some details.

Anyway, libtool library objects (.la) are usually not used when cross-compiling since libtool hardcode runpath (usually /usr/lib) in them and try to resolve library dependencies with what it found there. Then, the linker complains the format of the library (compiled for your host system) is not recognized.

comment:3 Changed 12 years ago by dacb

I can profide some details for this ticket (which applies to all current revisions):

jpeg6b fails to compile on 3535 through 3586 (specifically testing 3536, 3554, 3555, 3556, 3583 and 3586). jpeg6b library compilation fails when the library's make looks for libtool in openwrt/build_mipsel/jpeg-6b as ./libtool. See the Makefile in openwrt/build_mipsel/jpeg-6b for more information. jpeg6b can be made to compile by doing:

cp openwrt/build_mipsel/libpng-1.2.8-config/libtool openwrt/build_mipsel/jpeg6b

make

comment:4 Changed 12 years ago by dacb

build error looks like:

make[5]: Entering directory `/home/dacb/wgt634u/3535/openwrt/build_mipsel/jpeg-6b'
./libtool --mode=compile /home/dacb/wgt634u/3535/openwrt/staging_dir_mipsel/bin/mipsel-linux-uclibc-gcc -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time  -I/home/dacb/wgt634u/3535/openwrt/staging_dir_mipsel/usr/include -I/home/dacb/wgt634u/3535/openwrt/staging_dir_mipsel/include -I. -c ./jcapimin.c
make[5]: ./libtool: Command not found
make[5]: *** [jcapimin.lo] Error 127
make[5]: Leaving directory `/home/dacb/wgt634u/3535/openwrt/build_mipsel/jpeg-6b'
make[4]: *** [/home/dacb/wgt634u/3535/openwrt/build_mipsel/jpeg-6b/.built] Error 2
make[4]: Leaving directory `/home/dacb/wgt634u/3535/openwrt/package/jpeg'
make[3]: *** [compile] Error 2
make[3]: Leaving directory `/home/dacb/wgt634u/3535/openwrt/package/jpeg'
make[2]: *** [jpeg-compile] Error 2
make[2]: Leaving directory `/home/dacb/wgt634u/3535/openwrt/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/home/dacb/wgt634u/3535/openwrt'
make: *** [world] Error 2

comment:5 Changed 12 years ago by florian

I was not able to reproduce the bug with either the buildroot or the sdk. Please try with a fresh svn copy and indicate which compiler version you are using. Thanks.

comment:6 follow-up: Changed 12 years ago by florian

  • Resolution set to invalid
  • Status changed from assigned to closed

Since the bug can not be reproduced an no one has reported errors, this bug is now closed.

comment:7 in reply to: ↑ 6 Changed 10 years ago by anonymous

Replying to florian:

Since the bug can not be reproduced an no one has reported errors, this bug is now closed.

I had the same bug. To reproduce:

  1. check out kamikaze 7.09
  2. check out packages (I used revision 10154)
  3. link jpeg to kamikaze_7.09/package
  4. compile with libjpeg

-> link to "libtool" is places in build_mipsel/libjpeg... which does not work

cheers,
thorsten

comment:8 Changed 10 years ago by mk144210@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Same bug. Gutsy Gibbon 7.10

 gcc --version
gcc (GCC) 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

comment:9 Changed 10 years ago by anonymous

Works for me with Gutsy Gibbon 7.10 and latest trunk.

comment:10 Changed 10 years ago by Misha Koshelev <mk144210@…>

Are you using latest trunk of packages or kamikaze?

I am talking about latest trunk of packages and kamikaze_7.09, not the latest trunk of kamikaze.

Thank you
Misha

comment:11 Changed 10 years ago by anonymous

Latest packages will fail to compile for 7.09 and will never be fixed. 7.09 has a hardcoded packages revision in menuconfig.

Use trunk with latest packages revision.

comment:12 Changed 10 years ago by florian

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:13 Changed 10 years ago by mk144210@…

Aha so even using make package/symlinks on 7.09 libjpeg failed to build with same error. Prob is there _is no_ package/libtool in 7.09 and libtool does not get created. Will keep trying.

comment:14 Changed 10 years ago by mk144210@…

Pls help... Anyone have a libtool/libltdl Makefile that works for 7.09? I am having probs if I just pull in the one from SVN and there doesn't seem to be such a package in 7.09 at all which means I can't compile what I need...

comment:15 Changed 10 years ago by guillermo@…

Hello, I also had this issue. This is what I did.
1st: I linked ./libtool with libpng
2nd: I did the same with ltmain.sh
and it works fine.
By the way, I've changed Makefile to fit it up with the code and made a diff file (patch to apply) diff -u Makefile-orig Makefile > 999-Makefile.patch

comment:16 Changed 10 years ago by ulf

i fixed it with
cp ./toolchain_build_i386/gcc-4.1.2-final/i386-linux-uclibc/libssp/libtool ./build_i386/jpeg-6b/libtool
kamikaze 7.09 x86

comment:17 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.