Modify

Opened 10 years ago

Closed 10 years ago

#3799 closed defect (fixed)

trunk doesnt compile on brcm47xx 2.6 rev 11897

Reported by: anonymous Owned by: juhosg
Priority: highest Milestone:
Component: base system Version:
Keywords: Cc:

Description

ipkg-build -c -o 0 -g 0 /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/base-files/ipkg/uclibc
/mnt/data/Openwrt/trunk/bin/packages/mipsel
Packaged contents of /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/base-files/ipkg/uclibc into
/mnt/data/Openwrt/trunk/bin/packages/mipsel/uclibc_0.9.29-13_mipsel.ipk
WARNING: skipping ldd -- package not selected
WARNING: skipping ldconfig -- package not selected
make[3]: Leaving directory `/mnt/data/Openwrt/trunk/package/base-files'
make[3]: Entering directory `/mnt/data/Openwrt/trunk/package/bridge-utils'
make[3]: Leaving directory `/mnt/data/Openwrt/trunk/package/bridge-utils'
make[3]: Entering directory `/mnt/data/Openwrt/trunk/package/broadcom-diag'
make -C "/mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/linux-2.6.25.10" CROSS_COMPILE="mipsel-linux-uclibc-" ARCH="mips"
SUBDIRS="/mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag" EXTRA_CFLAGS="" modules
make[4]: Entering directory `/mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/linux-2.6.25.10'

CC [M] /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag/diag.o

In file included from include/asm-mips/mach-bcm47xx/gpio.h:62,

from include/asm/gpio.h:4,
from include/linux/gpio.h:7,
from /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag/gpio.h:9,
from /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag/diag.c:46:

include/asm-generic/gpio.h:110: error: redefinition of 'gpio_is_valid'
include/asm-mips/mach-bcm47xx/gpio.h:57: error: previous definition of 'gpio_is_valid' was here
make[5]: * /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag/diag.o Error 1
make[4]:
* [_module_/mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag] Error 2
make[4]: Leaving directory `/mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/linux-2.6.25.10'
make[3]: * /mnt/data/Openwrt/trunk/build_dir/linux-brcm47xx/broadcom-diag/.built Error 2
make[3]: Leaving directory `/mnt/data/Openwrt/trunk/package/broadcom-diag'
make[2]:
* [package/broadcom-diag/compile] Error 2
make[2]: Leaving directory `/mnt/data/Openwrt/trunk'
make[1]: * /mnt/data/Openwrt/trunk/staging_dir/mipsel/stamp/.package_compile Error 2
make[1]: Leaving directory `/mnt/data/Openwrt/trunk'
make:
* [world] Fehler 2

Attachments (1)

as (2.3 KB) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by michu at neophob.com

confirmed, same error with r11900

comment:2 Changed 10 years ago by anonymous

for me too

comment:3 Changed 10 years ago by michu at neophob.com

looks like we need to remove the 710-add-gpio-is-valid.patch - I'm testing it right now!

comment:4 Changed 10 years ago by michu at neophob.com

this worked fine, remove the file from the target/linux/brcm47xx/patches-2.6.25 directory

comment:5 Changed 10 years ago by juhosg

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:6 Changed 10 years ago by juhosg

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [11907].

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.