Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3780 closed defect (fixed)

openssh broken, needs libssp to run

Reported by: petrliebman@… Owned by: developers
Priority: normal Milestone: Kamikaze 8.09
Component: packages Version:
Keywords: Cc:

Description

openssh needs libssp.so.0 provided by libssp package, otherwise it will not run (compiles fine, but runtime error).

I saw that utils/mksh/Makefile adds libssp dependency only if gcc v4 is used, not sure the same applies to openssh.

So Package/openssh-client and Package/openssh-server needs something like:

DEPENDS:=+libssp

I'm using trunk revision r11744 and x86 target platform.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [11876].

comment:2 Changed 10 years ago by anonymous

for me openssh works without libssp client and server
im using brcm47xx 2.6.25.10 rev 11875
so i think the patch is only needed for x86...

greets

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.