Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#3767 closed defect (invalid)

Atheros Kernel Panic - Not Syncing : Attempt to kill init!

Reported by: arete@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: atheros kernel panic Cc:

Description

I have the last svn.
I have compilated for atheros(fonera), but i have this message

Kernel Panic - Not Syncing : Attempt to kill init!

Attachments (0)

Change History (11)

comment:1 Changed 10 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

incomplete bug report, no details about further kernel messages, flashing procedure, etc.
closing

comment:2 Changed 9 years ago by harald@…

Hi, i can reproduce this bug with r12249 and r12280 on a fonera+, thus please reopen the ticket.

The output on the serial console is:

+Ethernet eth0: MAC address 00:18:84:a0:dc:6c
IP: 192.168.1.1/255.255.255.0, Gateway: 0.0.0.0
Default server: 192.168.1.254

RedBoot(tm) bootstrap and debug environment [ROMRAM]
OpenWrt certified release, version 1.1 - built 22:32:28, May  7 2007

Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.

Board: FON 2201
RAM: 0x80000000-0x81000000, [0x80040290-0x80fe1000] available
FLASH: 0xa8000000 - 0xa87f0000, 128 blocks of 0x00010000 bytes each.
== Executing boot script in 10.000 seconds - enter ^C to abort
RedBoot> fis load -l vmlinux.bin.l7
Image loaded from 0x80041000-0x80281085
RedBoot> exec
Now booting linux kernel:
 Base address 0x80030000 Entry 0x80041000
 Cmdline :
Linux version 2.6.26.2 (harald@kaputtnick) (gcc version 4.1.2) #2 Mon Aug 11 228
CPU revision is: 00019064 (MIPS 4KEc)
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal          0 ->     4096
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0:        0 ->     4096
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/pret
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
PID hash table entries: 64 (order: 6, 256 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13568k/16384k available (1872k kernel code, 2816k reserved, 306k data, )
SLUB: Genslabs=6, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Mount-cache hash table entries: 512
net_namespace: 484 bytes
NET: Registered protocol family 16
Radio config found at offset 0xf8(0x1f8)
AR531x PCI init...
registering PCI controller with io_map_base unset
done
PCI: fixing up device 0,3,0
PCI: Failed to allocate mem resource #1:4000000@84000000 for 0000:00:00.0
PCI: Failed to allocate mem resource #1:4000000@84000000 for 0000:00:01.0
PCI: Failed to allocate mem resource #1:4000000@84000000 for 0000:00:02.0
PCI: Failed to allocate mem resource #1:4000000@84000000 for 0000:00:03.0
PCI: Failed to allocate mem resource #2:400000@81400000 for 0000:00:03.0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
ar531x: Registering GPIODEV device
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 26
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
Serial: 8250/16550 driver $Revision: 1.90 $ 1 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0xb1100003 (irq = 37) is a 16550A
eth0: Atheros AR231x: 00:18:84:a0:dc:6c, irq 4
ar2313_eth_mii: probed
eth0: Marvell 88E6060 PHY driver attached.
eth0: attached PHY driver [Marvell 88E6060] (mii_bus:phy_addr=0:1f)
cmdlinepart partition parsing not available
Searching for RedBoot partition table in spiflash at offset 0x7d0000
Searching for RedBoot partition table in spiflash at offset 0x7e0000
5 RedBoot partitions found on MTD device spiflash
Creating 5 MTD partitions on "spiflash":
0x00000000-0x00030000 : "RedBoot"
0x00030000-0x000f0000 : "vmlinux.bin.l7"
0x000f0000-0x007e0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=210000, len=5D0000
0x00210000-0x007e0000 : "rootfs_data"
0x007e0000-0x007ef000 : "FIS directory"
0x007ef000-0x007f0000 : "RedBoot config"
Registered led device: gpio0
Registered led device: gpio1
Registered led device: wlan
Registered led device: gpio3
Registered led device: gpio4
Registered led device: gpio7
eth0: Configuring MAC for full duplex
nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP vegas registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 128k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
Kernel panic - not syncing: Attempted to kill init!

That's not too meaningful - is there any way to get better debugging output?

That's the log from flashing:

RedBoot> load -r -b %{FREEMEMLO} openwrt-atheros-vmlinux.lzma
Using default protocol (TFTP)
Raw file loaded 0x80040400-0x801003ff, assumed entry at 0x80040400
RedBoot> fis init
About to initialize [format] FLASH image system - continue (y/n)? y
*** Initialize FLASH Image System
... Erase from 0xa87e0000-0xa87f0000: .
... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .
RedBoot> fis create -e 0x80041000 -r 0x80041000 vmlinux.bin.l7
... Erase from 0xa8030000-0xa80f0000: ............
... Program from 0x80040400-0x80100400 at 0xa8030000: ............
... Erase from 0xa87e0000-0xa87f0000: .
... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .
RedBoot> fis free
  0xA80F0000 .. 0xA87E0000
RedBoot> load -r -b %{FREEMEMLO} openwrt-atheros-root.squashfs
Using default protocol (TFTP)
Raw file loaded 0x80040400-0x801803ff, assumed entry at 0x80040400
RedBoot> fis create -l 0x006F0000 rootfs
... Erase from 0xa80f0000-0xa87e0000: ...............................................................................................................
... Program from 0x80040400-0x80180400 at 0xa80f0000: ....................
... Erase from 0xa87e0000-0xa87f0000: .
... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .
RedBoot> fconfig boot_script_data
boot_script_data:
.. fis load -b 0x80100000 loader
..  go 0x80100000
Enter script, terminate with empty line
>> fis load -l vmlinux.bin.l7
>> exec
>>
Update RedBoot non-volatile configuration - continue (y/n)? y
... Erase from 0xa87e0000-0xa87f0000: .
... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

Please let me know if you need any additional info.

Harald

comment:3 Changed 9 years ago by anonymous

Same result as Harald with latest svn here.

comment:4 Changed 9 years ago by nbd

Was this a fresh checkout or an incremental update? Did you reset your config?

comment:5 follow-up: Changed 9 years ago by harald@…

Sorry, forgot to update this ticket: In my case it turned out it was my own error - did accidentally remove some important packages from the image. I think the real defect here is, that openwrt fails to give any helpful diagnostic output on the serial console.

HTH,
Harald

comment:6 Changed 9 years ago by dksiwal@…

hi harald,

What was the important package you forgot to include , i am also facing the same problem , please suggest.

comment:7 in reply to: ↑ 5 Changed 9 years ago by anonymous

Replying to harald@lefant.net:

Sorry, forgot to update this ticket: In my case it turned out it was my own error - did accidentally remove some important packages from the image. I think the real defect here is, that openwrt fails to give any helpful diagnostic output on the serial console.

HTH,
Harald

hi harald,

What was the problem with you , which package did you forget to include , i am also facing the same problem with fonera , can you suggest ?

comment:8 Changed 9 years ago by harald@…

Sorry, I don't remember exactly which package I forgot. I think it was something like hotplug2 or udevtrigger. My advice is: Just stay to the default package selection of openwrt. You might add packages, but be careful when removing them.

It would be helpful when working on custom firmwares if openwrt had some minimal bootable image config somewhere, but that's an other story ...

Harald

comment:9 Changed 9 years ago by anonymous

Having the same problem as above using the UBNT, LZMA and Squashfs with the same documented procedure as above. The unit hangs on INIT in the CMD LINE. This is with pre-compiled images.

comment:10 Changed 9 years ago by anonymous

I am having the same problem.

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.