Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#376 closed enhancement (wontfix)

Bad generation of the bb_config.h file

Reported by: vincent.cuissard@… Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: other Version: 1.0
Keywords: Cc:

Description

After making the .config file, when I run 'make' I have this following error:

[...]
busybox/applets/applets.c: In function `run_applet_by_name':
busybox/applets/applets.c:455: `ENABLE_FEATURE_SUID' undeclared (first use in this function)
busybox/applets/applets.c:455: (Each undeclared identifier is reported only once
busybox/applets/applets.c:455: for each function it appears in.)
[...]

I saw that someone already reports this error but I don't think that the problem was the same of mine.

After looking after this error I found that the bb_config.h header wasn't generated correctly. In fact, all '\n' was written as '1n'.

The problem is in the Makefile in the rules include/bb_config.h. You use the binary sed to generate this file and on MacOSX (my dev platform) it seems that you cannot use '\n' in replacement.

To fix it, I changed the sed calls by 'perl -pe' and modify the regexp to work in perl language.

Something like:

@perl -pe "s/#undef CONFIG_(.*)/#define ENABLE_\1 0/;\
s/#define CONFIG_(.*)/#define CONFIG_\1\n#define ENABLE_\1/;\

< $< >> $@

Best regards

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by kaloz

  • Resolution set to wontfix
  • Status changed from new to closed
  • Type changed from defect to enhancement

We don't support MacOS X as a developer platform, and we won't add dependency on perl (even if it's installed on almost every box).

comment:2 Changed 12 years ago by mbm

  • Milestone set to 2.0

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.