Modify

Opened 10 years ago

Closed 10 years ago

#3746 closed defect (fixed)

Cannot build perl

Reported by: quentin@… Owned by: developers
Priority: normal Milestone: Kamikaze 8.09
Component: packages Version:
Keywords: perl Cc:

Description

perl, the non microperl version, fails to build, with the error:
make[4]: Entering directory `/u/home/hsn/openwrt/kamikaze/trunk/build_dir/mipsel/perl/perl-5.10.0/ext/DB_File'
cp DB_File.pm ../../lib/DB_File.pm
AutoSplitting ../../lib/DB_File.pm (../../lib/auto/DB_File)
mipsel-linux-uclibc-gcc -c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -DUSE_CROSS_COMPILE -I/u/home/hsn/openwrt/kamikaze/trunk/staging_dir/mipsel/include -I/u/home/hsn/openwrt/kamikaze/trunk/staging_dir/mipsel/usr/include -O2 -DVERSION=\"1.816_1\" -DXS_VERSION=\"1.816_1\" -fPIC "-I../.." version.c
version.c:30:16: error: db.h: No such file or directory

I have tried with no sub-packages of perl selected, and also with all sub-packages selected, and I still get this error.

The full output of make package/lang/perl V=99 is attached.

svn version is 11779

Could there be a dependency missing that isn't specified in the Makefile?

Attachments (1)

perl.build.err (215.0 KB) - added by quentin@… 10 years ago.
Output of make package/lang/perl V=99

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by quentin@…

Output of make package/lang/perl V=99

comment:1 Changed 10 years ago by blogic

  • Milestone set to Kamikaze 808

comment:2 Changed 10 years ago by dm8tbr@…

dm8tbr@fortinbras:~/src/kamikaze$ ./scripts/feeds install libdb

fixed this for me

comment:3 Changed 10 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.