Modify

Opened 10 years ago

Closed 8 years ago

#3728 closed defect (wontfix)

insmod ipv6: unresolved symbol tcp_destroy_sock

Reported by: candrews@… Owned by: thepeople
Priority: normal Milestone: Kamikaze 7.09
Component: kernel Version: Trunk
Keywords: Cc:

Description

I used ipkg to install kmod-ipv6, then did:
root@OpenWrt:~# insmod ipv6
insmod: unresolved symbol tcp_destroy_sock

I cannot find anyway to fix this - does the kernel need to be compiled with different parameters?

Attachments (0)

Change History (8)

comment:1 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

This is weird, my 7.09 router has ipv6 support enabled, and I see no such problems, please make sure you did not change anything in the networking options of your kernel.

comment:2 Changed 9 years ago by lorenzo@…

I've the same problem, i think it's caused by an error in brcm2.4 kernel compilation... please check it up
(I'm using Kamikaze 8.09 - Brcm 2.4, on an Asus WL500g Premium V1 Router)

comment:3 Changed 9 years ago by anonymous

Firmware	OpenWrt Kamikaze - With X-Wrt Extensions 8.09
Kernel	  	Linux 2.4.35.4 #15 Thu Nov 6 13:53:37 CST 2008
MAC	  	00:0F:66:C7:XX:XX
Device	 	Linksys WRT54G/GS/GL
Board	 	Broadcom BCM4712 chip rev 1

KAMIKAZE (8.09, r13132)

using:
http://downloads.x-wrt.org/xwrt/kamikaze/8.09_RC1/brcm-2.4/default/openwrt-brcm-2.4-squashfs.trx

i still get:

root@OpenWrt:~# insmod ipv6
insmod: unresolved symbol tcp_destroy_sock

comment:4 Changed 9 years ago by jow

This happens if the used kernel was built without kmod-ipv6 enabled, it does not contain required symbols then.

comment:5 Changed 8 years ago by fgiunchedi+ow@…

looks like this isn't fixed yet (at least in xwrt from http://downloads.x-wrt.org/xwrt/kamikaze/8.09.2/brcm-2.4/default/openwrt-brcm-2.4-squashfs.trx)

KAMIKAZE (8.09.2, r18961)

# insmod ipv6
insmod: unresolved symbol tcp_destroy_sock

comment:6 Changed 8 years ago by jenslink@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Just stumbled upon this bug yesterday evening using a Linksys WTR54GL 1.1 and 8.09.2

Workaround: Installed 7.09.

comment:7 Changed 8 years ago by nico

  • Owner changed from developers to thepeople
  • Status changed from reopened to assigned
  • Version set to Trunk

It seems x-wrt 8.09 images were built without IPv6 support...

comment:8 Changed 8 years ago by nico

  • Resolution set to wontfix
  • Status changed from assigned to closed

Too old, closing...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.