Modify

Opened 10 years ago

Closed 10 years ago

#3719 closed defect (fixed)

AVR32 u-boot is always compiled, even if CONFIG_AVR32_UBOOT is not set

Reported by: basmevissen Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: AVR32 UBOOT U-BOOT Cc:

Description

Even if the setting CONFIG_AVR32_UBOOT is NOT set, OpenWRT tries to compile u-boot. This fails.
Cause is that u-boot compilation needs CONFIG_AVR32_UBOOT_TARGET, which is not defined when CONFIG_AVR32_UBOOT is not defined.

Work-around is to always enable CONFIG_AVR32_UBOOT and hence CONFIG_AVR32_UBOOT_TARGET can be set correctly in "make menuconfig". Default value of "atngw100" is fine if you compile for such a board.

Solution is to really make compilation of u-boot dependant on CONFIG_AVR32_UBOOT being set or not, as was probably intended in changset 10961.

Tested against revision 11629. Issue is there since revision 10961.

More information:
Changeset causing defect:
https://dev.openwrt.org/cgi-bin/trac.fcgi/changeset/10961

File that might need to change:
https://dev.openwrt.org/cgi-bin/trac.fcgi/browser/trunk/target/linux/avr32/image/u-boot/Makefile

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by thepeople

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.