Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#3558 closed defect (fixed)

kmod-nfsd fails to load

Reported by: cozmic Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: nfs nfsd Cc:

Description

The nfsd kernel module does not load because of unresolved symbols (using r11522 on a WGT634U):

Linux version 2.6.25.6 (cosi@cozmic) (gcc version 4.1.2) #1 Tue Jun 17 14:57:51 CEST 2008
console [early0] enabled
CPU revision is: 00029007 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x05, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: IPSEC (cc 0x80B, rev 0x01, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x02, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x01, vendor 0x4243)
ssb: Core 6 found: MEMC SDRAM (cc 0x80F, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0804, irq 0 => 3
early_nvram_init: WGT634U NVRAM found.

...

nfsd: Unknown symbol gss_mech_get_by_pseudoflavor
nfsd: Unknown symbol gss_pseudoflavor_to_service
nfsd: Unknown symbol gss_mech_put
nfsd: Unknown symbol svcauth_gss_flavor

Attachments (1)

nfsd.patch (475 bytes) - added by cozmic 10 years ago.
Remove nfsd support for v4 in kernel 2.6.25

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by cozmic

According to http://forum.openwrt.org/viewtopic.php?id=15883 the problem is caused because the kernel is configured with nfsd v4 support.
When v4 support is removed, it works.

Changed 10 years ago by cozmic

Remove nfsd support for v4 in kernel 2.6.25

comment:2 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [11875].

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.