Modify

Opened 10 years ago

Closed 9 years ago

Last modified 4 years ago

#3530 closed defect (fixed)

The default asterisk.conf default contains the buildroot path when pre-build with the openwrt image

Reported by: chris@… Owned by: zandbelt
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: asterisk Cc:

Description

The default asterisk.conf default contains the buildroot path when pre-build with the openwrt image. This results in unnecessary directories being build when the device is first installed

It is easy to resolve the resulting problems (1) modify the asterisk.conf file with correct paths, and (2) remove the bogus directories that where created

However it would be nice to fix it in the source, and it may have an impact on the asterisk startup issue that I and others have reported. ie: the default path for the control file is not where it is expected to be so "asterisk -r" doest start correctly.

This is the contents of my asterisk.conf file after a build

root@OpenWrt:/etc/asterisk# cat asterisk.conf 
[directories]
astetcdir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/etc/asterisk
astmoddir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/usr/lib/asterisk/modules
astvarlibdir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/usr/lib/asterisk
astdatadir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/usr/lib/asterisk
astagidir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/usr/lib/asterisk/agi-bin
astspooldir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/var/spool/asterisk
astrundir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/var/run
astlogdir => /home/cmartin/Desktop/openwrt/kamikaze/trunk/build_dir/mipsel/root-brcm-2.4/var/log/asterisk

I have only just discovered this issue, So I have gone back over the last few builds that I have deployed and they have all experienced the same problem for over 1 month. I have never noticed it before as the next step in my deployment is to drop a tar-ball that contains the configuration files that I need for each router. This overwrites the default asterisk.conf file

NOTE: I am not building and deploying Asterisk as a separate package, but rather it is built into the trx image. I do this for both "space" and "speed/ease of deployment".

If I build as a separate package - then the installation script installs and updates the config file correctly. This only occurs when it is re-build into the image

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by anonymous

Dupe of #2773, although this has a good bit more information.

comment:2 Changed 9 years ago by chris@…

I have just done a bit more testing to see if this problem is still present in trunk. I have found that the bogus path is also listed in:

/etc/default/asterisk/
and
/etc/init.d/asterisk

Again this problem only occurs if you build asterisk into the openwrt image. If you build it as a seperate package you will NOT find this.

comment:3 Changed 9 years ago by zandbelt

  • Owner changed from developers to zandbelt
  • Status changed from new to assigned

comment:4 Changed 9 years ago by zandbelt

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in [13685]

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.