Opened 10 years ago

Closed 10 years ago

Last modified 3 years ago

#3484 closed defect (fixed)

Danube support

Reported by: mark.wehner@… Owned by: blogic
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:



I have compiled the openwrt project (Revision 11276) for infineon mips [2.6] targets.
However, it does not work. I have updated the uboot at first and then the squashfs.image. Nevertheless, the kernel could not be started:

Image Name: MIPS OpenWrt Linux-
Created: 2008-05-28 7:03:21 UTC
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 814522 Bytes = 795.4 kB
Load Address: 80002000
Entry Point: 80002000
Verifying Checksum ... OK
Uncompressing Kernel Image ... ERROR: LzmaDecode.c, 543

Decoding error = 1
LZMA ERROR 1 - must RESET board to recover.

When I try the original uboot (with adapted partitions) and update the kernel and the rootfs from the openwrt-project (Revision 11276), linux will boot.

Nevertheless, ethernet does not work...

I have used "make kernel_menuconfig" to enable the ifx_eth device drive.
Are there further options which I have to choose?

Which Danube specific HW (for example USB, both MII, ...) is already supported?



Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by blogic

  • Owner changed from developers to blogic

mii is support, mei is in trunk but not tested
usb will hopefully work soon.
pci is broken, but we are are working on this at the moment.
wdt, gpio, led, buttons, .... are all supported
voip and dsl ... will come, but not tomorrow

does ifconfig show the eth0 device ? or does the ethernet not work for you at all ?

comment:2 Changed 10 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 9 years ago by lucadit@…

request to Falcon83 or blogic:
i am interested in the danube development, how do i get in the developersgroup pls?
pls drop me a mail so that i can ramp up on openWRT for danube platform.

comment:4 Changed 5 years ago by anonymous

How this issue is solved?

comment:5 Changed 5 years ago by malay.gopani@…

How this issue is solved?

comment:6 Changed 3 years ago by anonymous

ERROR: LzmaDecode.c, 543
Decoding error = 1

LZMA ERROR 1 - must RESET board to recover.
I want to konw why this err occur?

and how i solute it?

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.