Modify

Opened 10 years ago

Closed 7 years ago

#3360 closed enhancement (duplicate)

pulseaudio - one step closer

Reported by: michu-at-neophobdotcom Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Adding this patch to the pulseaudio package:

Index: package/feeds/packages/pulseaudio/Makefile
===================================================================
--- package/feeds/packages/pulseaudio/Makefile  (revision 10857)
+++ package/feeds/packages/pulseaudio/Makefile  (working copy)
@@ -40,6 +40,7 @@
        --disable-hal \
        --disable-gconf \
        --disable-tcpwrap \
+       --disable-manpages \

 CONFIGURE_VARS += \
        PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \

results in a new error:

michux/trunk/staging_dir/mipsel/usr/lib -lsndfile    -L/home/michux/trunk/staging_dir/mipsel/usr/lib/  libspeex-resampler-fixed.la libspeex-resampler-float.la libffmpeg-resampler.la -lrt -ldl -lm  -latomic_ops
libtool: link: cannot find the library `../libltdl/libltdl.la' or unhandled argument `../libltdl/libltdl.la'
make[6]: *** [libpulsecore.la] Error 1
make[6]: Leaving directory `/home/michux/trunk/build_dir/mipsel/pulseaudio-0.9.10/src'

Attachments (4)

pulseaudio-0.9.13.diff (6.0 KB) - added by dwrobel@… 9 years ago.
pulseaudio-0.9.13.diff
disable-tls.diff (530 bytes) - added by dwrobel@… 9 years ago.
disable-tls.diff (reverts changeset #10782)
patches-and-config-svn13055.tar.bz2 (15.6 KB) - added by dwrobel@… 9 years ago.
patches-and-config-svn13055.tar.bz2 (config file & all patches against svn13055 I'm currently using to build the pulseaudio)
build-svn13055.log.2.bz2 (574.7 KB) - added by dwrobel@… 9 years ago.
the complete build log (svn13055 vanilla sources + patches as per my previous attachment)

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by michu at neophob.com

There are some troubles linking libltdl so I disabled it (what does ltdl-install do, anyway?). also the X_CFLAGS made some errors, this needs to be removed as well.

Index: Makefile
===================================================================
--- Makefile    (revision 11909)
+++ Makefile    (working copy)
@@ -33,13 +33,15 @@
        --with-system-group=root \
        --with-realtime-group=root \
        --with-access-group=root \
-       --without-x \
+       --with-x=no \
        --enable-static-bins \
-       --enable-ltdl-install \
        --disable-dbus \
        --disable-hal \
+       --disable-manpages \
        --disable-gconf \
        --disable-tcpwrap \
+       --disable-xmltoman \

 CONFIGURE_VARS += \
        PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
@@ -52,9 +54,7 @@
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib $(SUPP_LIBS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               X_CFLAGS="" \
-               all install
+               DESTDIR="$(PKG_INSTALL_DIR)"
 endef

Compiling now ends here:

mv -f .deps/libpulse_la-poll.Tpo .deps/libpulse_la-poll.Plo
/bin/sh ../libtool --tag=CC   --mode=compile mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I..   -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -I/home/michux/trunk2/trunk/staging_dir/mipsel/include  -I../src -I../src/modules -I../src/modules/rtp -I../src/modules/gconf -pthread -D_POSIX_PTHREAD_SEMANTICS  -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include   -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include   -DPA_DLSEARCHPATH=\"/usr/lib/pulse-0.9/modules/\" -DPA_DEFAULT_CONFIG_DIR=\"/etc/pulse\" -DPA_BINARY=\"/usr/bin/pulseaudio\" -DPA_SYSTEM_RUNTIME_PATH=\"/var/run/pulse\" -DAO_REQUIRE_CAS '-DDEBUG_TRAP=__asm__("int $3")' -I/usr/include  -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -I/home/michux/trunk2/trunk/staging_dir/mipsel/include -MT libpulse_la-pstream.lo -MD -MP -MF .deps/libpulse_la-pstream.Tpo -c -o libpulse_la-pstream.lo `test -f 'pulsecore/pstream.c' || echo './'`pulsecore/pstream.c
 mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I.. -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -I/home/michux/trunk2/trunk/staging_dir/mipsel/include -I../src -I../src/modules -I../src/modules/rtp -I../src/modules/gconf -pthread -D_POSIX_PTHREAD_SEMANTICS -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -DPA_DLSEARCHPATH=\"/usr/lib/pulse-0.9/modules/\" -DPA_DEFAULT_CONFIG_DIR=\"/etc/pulse\" -DPA_BINARY=\"/usr/bin/pulseaudio\" -DPA_SYSTEM_RUNTIME_PATH=\"/var/run/pulse\" -DAO_REQUIRE_CAS "-DDEBUG_TRAP=__asm__(\"int \$3\")" -I/usr/include -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -I/home/michux/trunk2/trunk/staging_dir/mipsel/usr/include -I/home/michux/trunk2/trunk/staging_dir/mipsel/include -MT libpulse_la-pstream.lo -MD -MP -MF .deps/libpulse_la-pstream.Tpo -c pulsecore/pstream.c  -fPIC -DPIC -o .libs/libpulse_la-pstream.o
{standard input}: Assembler messages:
{standard input}:2712: Error: unrecognized opcode `rorw $8,$3'
{standard input}:2712: Error: unrecognized opcode `rorl $16,$3'
{standard input}:2712: Error: unrecognized opcode `rorw $8,$3'
{standard input}:2779: Error: unrecognized opcode `rorw $8,$4'
{standard input}:2779: Error: unrecognized opcode `rorl $16,$4'
{standard input}:2779: Error: unrecognized opcode `rorw $8,$4'
{standard input}:2832: Error: unrecognized opcode `rorw $8,$5'
{standard input}:2832: Error: unrecognized opcode `rorl $16,$5'
{standard input}:2832: Error: unrecognized opcode `rorw $8,$5'
{standard input}:2868: Error: unrecognized opcode `rorw $8,$5'
{standard input}:2868: Error: unrecognized opcode `rorl $16,$5'
{standard input}:2868: Error: unrecognized opcode `rorw $8,$5'
{standard input}:2882: Error: unrecognized opcode `rorw $8,$5'
{standard input}:2882: Error: unrecognized opcode `rorl $16,$5'
...
{standard input}:3910: Error: unrecognized opcode `rorl $16,$2'
{standard input}:3910: Error: unrecognized opcode `rorw $8,$2'
make[6]: *** [libpulse_la-pstream.lo] Error 1
make[6]: Leaving directory `/home/michux/trunk2/trunk/build_dir/mipsel/pulseaudio-0.9.10/src'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/michux/trunk2/trunk/build_dir/mipsel/pulseaudio-0.9.10/src'

I'm using r11909 and bcm47xx 2.6 Kernel.

comment:2 Changed 9 years ago by michu-at-neophob-com

perhaps atomic ops error?

check http://pulseaudio.org/ticket/327

comment:3 Changed 9 years ago by fPonias

I was running in to this error and I knew the library was installed on my system.
It seemed make was looking for the library in at ../libltdl/libltdl.la so first I did a search for my installed library

find / libltdl.la 2>/dev/null

and it found a copy of it in /usr/lib/libltdl.la
so I made a subdirectory in my base directory where I ran ./configure called libltdl
and created a symlink to the original library in that directory

cd pulseaudio-0.9.12
mkdir libltdl
cd libltdl
ln -s /usr/lib/libltdl.la .

build a success!

Changed 9 years ago by dwrobel@…

pulseaudio-0.9.13.diff

Changed 9 years ago by dwrobel@…

disable-tls.diff (reverts changeset #10782)

comment:4 Changed 9 years ago by dwrobel@…

Applying both pulseaudio-0.9.13.diff & disable-tls.diff patches allows me to sucessfully compile the latest version of the pulse audio for mipsel (more precisely wgt634u).

However, an attempt to run it on build r10359 causes illegal instruction as follows:

Program received signal SIGILL, Illegal instruction.
0x2ab29d24 in pa_atomic_ptr_cmpxchg (a=0x2ab58db0, old_p=0x0, new_p=0x41f1b8)

at mips.h:42

42 asm volatile(
(gdb) bt
#0 0x2ab29d24 in pa_atomic_ptr_cmpxchg (a=0x2ab58db0, old_p=0x0,

new_p=0x41f1b8) at mips.h:42

#1 0x2ab2a1a8 in pa_once_begin (control=0x2ab58db0) at pulsecore/once.c:60
#2 0x2aad41fc in pa_init_i18n () at pulse/i18n.c:32
#3 0x00407df4 in main (argc=1, argv=0x7fc19e84) at daemon/main.c:414

comment:5 Changed 9 years ago by anonymous

Formatted version of the callstack:

Program received signal SIGILL, Illegal instruction.
0x2ab29d24 in pa_atomic_ptr_cmpxchg (a=0x2ab58db0, old_p=0x0, new_p=0x41f1b8)
    at mips.h:42
42	  __asm__ __volatile__(
(gdb) bt
#0  0x2ab29d24 in pa_atomic_ptr_cmpxchg (a=0x2ab58db0, old_p=0x0, 
    new_p=0x41f1b8) at mips.h:42
#1  0x2ab2a1a8 in pa_once_begin (control=0x2ab58db0) at pulsecore/once.c:60
#2  0x2aad41fc in pa_init_i18n () at pulse/i18n.c:32
#3  0x00407df4 in main (argc=1, argv=0x7fc19e84) at daemon/main.c:414

comment:6 Changed 9 years ago by dwrobel@…

Patch from the ticket #4086 seems to cure the illegal instruction problem.

comment:7 Changed 9 years ago by florian

I am still not able to build pulseaudio with your 0.9.13 patch. TLS support is WIP in uClibc thus I reverted the commit which disables it. Relevant parts of the build here :

.libs/pulseaudioS.o:(.rodata+0x7e624): undefined reference to `float32_init'
.libs/pulseaudioS.o:(.rodata+0x7e62c): undefined reference to `float32_le_read'
.libs/pulseaudioS.o:(.rodata+0x7e634): undefined reference to `float32_le_write'
.libs/pulseaudioS.o:(.rodata+0x7e63c): undefined reference to `double64_be_read'
.libs/pulseaudioS.o:(.rodata+0x7e644): undefined reference to `double64_be_write'
.libs/pulseaudioS.o:(.rodata+0x7e64c): undefined reference to `double64_init'
.libs/pulseaudioS.o:(.rodata+0x7e654): undefined reference to `double64_le_read'
.libs/pulseaudioS.o:(.rodata+0x7e65c): undefined reference to `double64_le_write'
.libs/pulseaudioS.o:(.rodata+0x7e664): undefined reference to `aiff_ima_init'
.libs/pulseaudioS.o:(.rodata+0x7e66c): undefined reference to `wav_w64_ima_init'
.libs/pulseaudioS.o:(.rodata+0x7e674): undefined reference to `msadpcm_write_adapt_coeffs'
.libs/pulseaudioS.o:(.rodata+0x7e67c): undefined reference to `wav_w64_msadpcm_init'
.libs/pulseaudioS.o:(.rodata+0x7e684): undefined reference to `gsm610_init'
.libs/pulseaudioS.o:(.rodata+0x7e68c): undefined reference to `dwvw_init'
.libs/pulseaudioS.o:(.rodata+0x7e694): undefined reference to `vox_adpcm_init'
.libs/pulseaudioS.o:(.rodata+0x7e69c): undefined reference to `interleave_init'
.libs/pulseaudioS.o:(.rodata+0x7e6a4): undefined reference to `psf_get_string'

and so on.

comment:8 Changed 9 years ago by anonymous

Which version of the libtool are you using? The 1.5.24 or the newest one 2.2.6a (the patch is available in ticket #4096)? If the latest one wouldn't help you I can give you my .config or any other relevant files - which should allows you to fully restore my configuration.

comment:9 Changed 9 years ago by florian

I am using the default libtool version, since the new one was not yet integrated. Will have a try with the new one.

Changed 9 years ago by dwrobel@…

patches-and-config-svn13055.tar.bz2 (config file & all patches against svn13055 I'm currently using to build the pulseaudio)

Changed 9 years ago by dwrobel@…

the complete build log (svn13055 vanilla sources + patches as per my previous attachment)

comment:10 Changed 9 years ago by d.wrobel@…

Hopefully it would help how to build up the pulseaudio.

comment:11 Changed 9 years ago by florian

Merged your pending patches in [13478].

comment:12 Changed 8 years ago by loswillios

comment:13 Changed 7 years ago by mirko

  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to Trunk

duplicate of #7983

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.