Modify

Opened 10 years ago

Closed 5 years ago

#3341 closed enhancement (obsolete)

some helper packages for huawei e220 modems

Reported by: pieterp@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc: pieterp@…

Description

I've created some packages/diffs for the HUAWEI e220 USB modems on kamikaze. Hope it helps some people. Should be self-explaining for those that have sufficient knowledge to be undertaking this.

Attachments (4)

he220stat.tar.gz (54.2 KB) - added by pieterp@… 10 years ago.
modem statistics program from http://oozie.fm.interia.pl/pro/huawei-e220/
huaweiAktBbo.tar.gz (2.4 KB) - added by pieterp@… 10 years ago.
he220 switch to modem tool from http://www.kanoistika.sk/bobovsky/archiv/umts/
usbserial-e220-id.patch (630 bytes) - added by pieterp@… 10 years ago.
add e220 device id to usbserial driver
01-huawei (2.0 KB) - added by pieterp@… 10 years ago.
very hackish hotplug script (for /etc/hotplug.d/usb) to automatically bring up th 3G upon device insertion. includes kill of pppd when the device is unplugged, and initial swith of to modem mode.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by pieterp@…

modem statistics program from http://oozie.fm.interia.pl/pro/huawei-e220/

Changed 10 years ago by pieterp@…

he220 switch to modem tool from http://www.kanoistika.sk/bobovsky/archiv/umts/

Changed 10 years ago by pieterp@…

add e220 device id to usbserial driver

comment:1 Changed 10 years ago by pieterp@…

one extra note: to obtain a decent speed on these modems, you have to run usbserial with a maxSize=2048 (or higher? I use 4096) parameter:

insmod usbserial maxSize=2048

for convenience add it to /etc/modules/60-usb-serial

usbserial maxSize=2048

comment:2 Changed 10 years ago by pieterp@…

The relevant section from /etc/config/network:

#### WAN configuration (3G)
config interface wan
    option ifname   'ppp0'
    option proto    '3g'
    option device   '/dev/usb/tts/0'
    option apn      'internet.vodafone.pt'

I chose to replace the wan connection with the 3g connection. (hardware: asus wl-500w)

Changed 10 years ago by pieterp@…

very hackish hotplug script (for /etc/hotplug.d/usb) to automatically bring up th 3G upon device insertion. includes kill of pppd when the device is unplugged, and initial swith of to modem mode.

comment:3 Changed 10 years ago by pedrofaustino

the user space configuration tool huaweiAktBbo was already added to trunk on revision 10226 but it would be a good idea to have a webif tab with the stats given by your package he220stat ;)

comment:4 Changed 10 years ago by pedrofaustino

Also, on r7630 support for Option HSDPA modems (and also Huawei E220, see ticket 1890) was added and on r8573 high-speed usb serial fix was added to kernel 2.4

comment:5 Changed 10 years ago by pieterp@…

the problem is (was?) that latest SVN didn't compile for me, so this indeed applies to an older version. If it's present/fixed, the better.

comment:6 Changed 9 years ago by Matthias Lohr <mail@…>

Why the stuff for argument usuage is commented out? I have to use 0x1001 as product id. Please change this.

comment:7 Changed 8 years ago by YourSexyMama

There is an error in 01-huawei (line 19):

It should be:
if [ -c /dev/usb/tts/0 ] && [ -c /dev/usb/tts/1 ] && [ -c /dev/usb/tts/2 ]; then

comment:8 Changed 5 years ago by florian

  • Version set to Trunk

Can someone cleanup these patches and make sure they interface properly with netifd?

comment:9 Changed 5 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.