Modify

Opened 10 years ago

Closed 10 years ago

#3275 closed defect (worksforme)

PPPOE doesn't come up on boot

Reported by: gregor@… Owned by: developers
Priority: normal Milestone: Kamikaze 7.09
Component: base system Version:
Keywords: Cc:

Description

Running Kamikaze 7.09, I have to bring up the WAN interface manually after boot (WAN is configured as PPPOE for a DSL connection).

Inserting an "ifup -a" in the boot() function of /etc/init.d/network fixes this problem for me, the interface now comes up automatically after a reboot. Looks valid, since both start() and restart() do "ifup -a" as well.

--- rom/etc/init.d/network	2008-03-22 23:52:45 +0100
+++ etc/init.d/network	2000-01-01 01:02:51 +0100
@@ -9,6 +9,7 @@
 
 	include /lib/network
 	setup_switch
+	ifup -a
 	[ -s /etc/config/wireless ] || \
 		/sbin/wifi detect > /etc/config/wireless
 	/sbin/wifi up

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with [10715].

comment:2 Changed 10 years ago by chris@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I am testing 10850 and the problem is still there. I too had to add "ifup -a" in /etc/init.d/network

comment:3 Changed 10 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

should be fixed in newer versions

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.