Modify

Opened 10 years ago

Last modified 3 years ago

#3263 reopened defect

Reading/writing to usb harddrive freezes Asus wl-500gP

Reported by: luna@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Kamikaze trunk
Keywords: Cc: luna@…

Description

When reading and/or writing to/from an USB harddrive the router freezes.

Possible workaround is to only access the harddrive using speeds less than 100kb/s (which is a bit silly).

Reference forum thread: http://forum.openwrt.org/viewtopic.php?id=11189

Attachments (0)

Change History (10)

comment:1 Changed 10 years ago by rabidus

I have the same problem. It is not however linked directly with Harddrive, it is linked with wifi connection.

Router hangs up when I am transfering data over 400MB, and this is random when it happens sometimes I can transfer as much as 1GB and nothing happens but in 90% of situation it will hang up earlier. It is not matter of one large file but continous trafer. When files are smaller I can download larger data amount with breaks about 5 min.
The easiest case of providing enough data is HDD.

  1. I used Samba, dowloaded from xwrt, and router hangs up
  2. I used different ftp clients, the same story (e.g. vsftpd)
  3. I used http transfer, again the same situation

Notice: When I am using wire connection everything wokring fine, I could transfer up to 8GB in one continous tranfer and nothing happend

My configuration is:

  • pppoe wan access
  • openwrt with samba 3.0 from xwrt (because proplem of vista)
  • HDD WD 250G with ext2 filestytem and one partition
  • 250 GB Swap
  • broadcome wireless module

wireless.cfg2=wifi-iface
wireless.cfg2.device=wl0
wireless.cfg2.network=lan
wireless.cfg2.mode=ap
wireless.cfg2.ssid=my_ssid
wireless.cfg2.key=*
wireless.cfg2.isolate=0
wireless.cfg2.encryption=psk

comment:2 Changed 10 years ago by Behemot

Same here, with cable it's ok, but wifi crashes everything during transfer of files from hdd.

comment:3 Changed 10 years ago by rene@…

Transferred huge amounts of data using a cable without problems. Using wireless (psk/wpa) and nas package. Freeze occurs after a few gigabytes. Is reproducable.

comment:4 Changed 9 years ago by battlehawk

Has someone found a fix meanwhile?

I can read so many threads and also problem reports that declare the problem as fixed. However I can't get the USB drive running correctly.

As soon as I write to the drive or delete more than one file at once the drive freezes the current task. No WLAN, no network traffic, no NFS share, no SAMBA as blamed for the problem in so many other threads. I use pure telnet to manage the file system (ext3).

The same harddrive and filesystem works correctly on a SLUG - not a single error.

I myself have a WD myBook - I start to believe that those cause the problem with the 500gP(V2)'s chipset...

I have some information that maybe help someone to figure out the main problem.

Here is dmesg on bootup (just USB relevant parts):

usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
Journalled Block Device driver loaded
SB USB20H init
SB COREREV: 2
SB USB20H resetting
USB20H fcr: 0x64
USB20H shim cr: 0x8f7
PCI: Setting latency timer of device 00:03.1 to 64
ehci_hcd 00:03.1: PCI device 14e4:471a
ehci_hcd 00:03.1: irq 6, pci mem b8003800
usb.c: new USB bus registered, assigned bus number 1
ehci_hcd 00:03.1: illegal capability!
ehci_hcd 00:03.1: USB 0.0 enabled, EHCI 1.00, driver 2003-Dec-29/2.4
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: $Revision: 1.275 $ time 17:17:23 Jan 17 2009
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
br-lan: port 1(eth0.0) entering disabled state
br-lan: port 1(eth0.0) entering learning state
br-lan: port 1(eth0.0) entering forwarding state
br-lan: topology change detected, propagating
hub.c: new USB device 00:03.1-1, assigned address 2
hub.c: USB hub found
hub.c: 2 ports detected
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.

How about this line?

ehci_hcd 00:03.1: illegal capability!

Further I have a dmesg dump made directly after the drive freezes:

USB Mass Storage device found at 3
usb.c: USB disconnect on device 00:03.1-1.2 address 3
hub.c: new USB device 00:03.1-1.2, assigned address 4
scsi1 : SCSI emulation for USB Mass Storage devices
  Vendor: WD        Model: 5000AA External   Rev: 200i
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sdb at scsi1, channel 0, id 0, lun 0
SCSI device sdb: 976773168 512-byte hdwr sectors (500108 MB)
 /dev/scsi/host1/bus0/target0/lun0: p1 p2 p3 p4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 4
EXT2-fs: sd(8,19): couldn't mount because of unsupported optional features (4).
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: mounting unchecked fs, running e2fsck is recommended
EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,19), internal journal
EXT3-fs: recovery complete.
...
...
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51768
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51769
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51770
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51771
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51772
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51773
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51774
EXT3-fs error (device sd(8,19)): ext3_free_blocks: bit already cleared for block 51724
EXT3-fs error (device sd(8,19)): ext3_free_inode: bit already cleared for inode 6445
EXT3-fs error (device sd(8,19)): ext3_free_inode: bit already cleared for inode 6446
EXT3-fs error (device sd(8,19)): ext3_free_inode: bit already cleared for inode 6312
EXT3-fs error (device sd(8,19)): ext3_free_inode: bit already cleared for inode 6312
usb-storage: Refusing to reset a multi-interface device
usb.c: USB disconnect on device 00:03.1-1.2 address 4
Device 08:13 not ready.
 I/O error: dev 08:13, sector 356
Device 08:13 not ready.

USB Mass Storage device found at 5
SCSI disk error : host 1 channel 0 id 0 lun 0 return code = 8000002
Current sd08:13: sns = 70  0
Raw sense data:0x70 0x00 0x00 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
 I/O error: dev 08:13, sector 0
SQUASHFS error: sb_bread failed reading block 0x0
EXT2-fs: sd(8,19): couldn't mount because of unsupported optional features (4).
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: mounting unchecked fs, running e2fsck is recommended
EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,19), internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.

The device seems to freeze even if no command is running. I just typed a new command and suddenly the terminal hangs. Maybe some caching mechanism that freezes the drive when flushing?

I even have to power off and on the WD since just replugging USB doesn't work... Strange
As I mentioned, the EXT3-fs errors just appear on the ASUS router. Maybe it is caused by the mass storage driver not responding anymore...

comment:5 follow-up: Changed 8 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed
  • Version set to Kamikaze trunk

should be working in newer versions

comment:6 in reply to: ↑ 5 Changed 8 years ago by anonymous

  • Resolution obsolete deleted
  • Status changed from closed to reopened

Replying to nbd:

should be working in newer versions

comment:7 Changed 8 years ago by zalan

It doesn't work for me with the "stable" backfire release and with kernel 2.6. I have Asus-wl 500gP v2. I have an 500 GB HDD. One partition is used for swap. On the other there is an ext3 filesystem. When I start ctorrent only for one upolad with maximum 200 KB/sec speed, after 1-3 days depends on the traffic the connection between the HDD and the router seems to be lost. I cannot ssh into the switch but I am able to reach any internet site using the router so the routing functionality is OK.

comment:8 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

sounds like an old bug that has been fixed a long time ago

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:10 Changed 3 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

freezes on samba are still relevant on barrier breaker.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.