Modify

Opened 10 years ago

Closed 10 years ago

#3257 closed defect (fixed)

[PATCH] Fix missing hwmon-vid module error on LM77 package build

Reported by: Acinonyx <acinonyxs@…> Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: Cc:

Description

mkdir -p /home/acinonyx/devel/git/openwrt/trunk/build_dir/linux-x86_generic/packages/ipkg/kmod-hwmon-core/lib/modules/2.6.24.2
cp -fpR -L /home/acinonyx/devel/git/openwrt/trunk/build_dir/linux-x86_generic/linux-2.6.24.2/drivers/hwmon/hwmon.ko /home/acinonyx/devel/git/openwrt/trunk/build_dir/linux-x86_generic/linux-2.6.24.2/drivers/hwmon/hwmon-vid.ko /home/acinonyx/devel/git/openwrt/trunk/build_dir/linux-x86_generic/packages/ipkg/kmod-hwmon-core/lib/modules/2.6.24.2/
cp: cannot stat `/home/acinonyx/devel/git/openwrt/trunk/build_dir/linux-x86_generic/linux-2.6.24.2/drivers/hwmon/hwmon-vid.ko': No such file or directory
make[3]: *** [/home/acinonyx/devel/git/openwrt/trunk/bin/packages//kmod-hwmon-core_2.6.24.2-x86-1_i386.ipk] Error 1
make[3]: Leaving directory `/home/acinonyx/devel/git/openwrt/trunk/package/kernel'
make[2]: *** [package/kernel/compile] Error 2
make[2]: Leaving directory `/home/acinonyx/devel/git/openwrt/trunk'
make[1]: *** [/home/acinonyx/devel/git/openwrt/trunk/staging_dir/i386/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/acinonyx/devel/git/openwrt/trunk'
make: *** [world] Error 2

The problem is that hwmon-vid is not a dependency for LM77 so it does not get build.

A patch fix follows

http://openwrt.acinonyx.ath.cx/gitweb/?p=openwrt/.git;a=commit;h=77bc504bf504b0f264fb5923322048e02dd600df

Signed-off-by: Vasilis Tsiligiannis <acinonyxs@…>

Attachments (1)

77bc504bf504b0f264fb5923322048e02dd600df.diff (1.6 KB) - added by Acinonyx <acinonyxs@…> 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Acinonyx <acinonyxs@…>

comment:1 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [10657].

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.