Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#3222 closed defect (fixed)

r10579: Random ntpclient related spam in dmesg

Reported by: nabcore Owned by: agb
Priority: low Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:

Description

Jan  1 00:00:11 Bunny user.info :     mode:         2
Jan  1 00:00:11 Bunny user.info : -o  offset:       0
Jan  1 00:00:11 Bunny user.info : -f  frequency:    0
Jan  1 00:00:11 Bunny user.info :     maxerror:     16384000
Jan  1 00:00:11 Bunny user.info :     esterror:     16384000
Jan  1 00:00:11 Bunny user.info :     status:       64 ( UNSYNC )
Jan  1 00:00:11 Bunny user.info : -p  timeconstant: 2
Jan  1 00:00:11 Bunny user.info :     precision:    1
Jan  1 00:00:11 Bunny user.info :     tolerance:    33554432
Jan  1 00:00:11 Bunny user.info : -t  tick:         10000
Jan  1 00:00:11 Bunny user.info :     time.tv_sec:  11
Jan  1 00:00:11 Bunny user.info :     time.tv_usec: 836295
Jan  1 00:00:11 Bunny user.info :     return value: 5 (clock not synchronized)

Attachments (1)

network_switch_fix.diff (364 bytes) - added by nabcore 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by nabcore

This was being caused by a typo in etc/init.d/network. Find the patch attached

Changed 10 years ago by nabcore

comment:2 Changed 10 years ago by nabcore

It seems that #3299 may be a dupe of this.

comment:3 Changed 10 years ago by nabcore

Ok,

setup_switch() { return 0; }

within boot() is an null function, and the #3299 error is a result of the fact that this is out of restart()'s scope. So that's not the solution to that bug, but a side bug that was found investigating it. This is fixed in r10846.

comment:4 Changed 10 years ago by anonymous

Current output with debug enabled in /lib/network/config.sh:

root@Bunny:/lib/network# ifup -a
ifconfig lo up
ifconfig lo 127.0.0.1 netmask 255.0.0.0 broadcast +
brctl addbr br-lan
brctl setfd br-lan 0
ifconfig br-lan up
brctl addif br-lan eth0
brctl stp br-lan off
    mode:         2
-o  offset:       0
-f  frequency:    0
    maxerror:     16384000
    esterror:     16384000
    status:       64 ( UNSYNC )
-p  timeconstant: 2
    precision:    1
    tolerance:    33554432
-t  tick:         10000
    time.tv_sec:  371
    time.tv_usec: 792439
    return value: 5 (clock not synchronized)
Plugin pppoatm.so loaded.

comment:5 Changed 10 years ago by nabcore

It seems the spurious output is from adjtimex (called via the ntpclient hotplug) which was add in r10355. Should the output of adjtimex be piped to /dev/null ?

comment:6 Changed 10 years ago by agb

  • Owner changed from developers to agb
  • Status changed from new to assigned

comment:7 Changed 10 years ago by agb

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [11103], thanks.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.