Modify

Opened 10 years ago

Closed 10 years ago

#3197 closed defect (fixed)

curl-7.17.1 compile problem

Reported by: bmilde@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

I did a complete svn trunk checkout yesterday (03/02/08) and updated all packages with the feeds script.

libcurl does not compile: (I'm building openwrt on a linux machine)


checking for working NI_WITHSCOPEID... no
checking if we are Mac OS X (to disable poll)... no
checking if poll works with NULL inputs... cross-compiling assumes yes
checking for perl... /usr/bin/perl
checking for gnroff... no
checking for nroff... /usr/bin/nroff
checking how to use *nroff to get plain text from man pages... failed
configure: WARNING: found no *nroff option to get plaintext from man pages
configure: WARNING: disabling built-in manual
checking whether to enable c-ares... no
checking whether to enable verbose strings... no
checking whether build target is a native Windows one... no
checking whether to enable SSPI support (Windows native builds only)... no
checking whether to enable debug options... no
checking whether to enable cryptographic authentication methods... yes
checking whether to enable support for cookies... yes
checking whether to enable hidden symbols in the library... no
configure: creating ./config.status
/bin/sh: error while loading shared libraries: <path to my working dir>/kamikaze-trunk/staging_dir/mips/usr/lib/libncurses.so.5: ELF file data encoding not little-endian


I'm building for the atheros platform. If further information is needed, I will provide it.

  • B.Milde

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by zioproto@…

Maybe this is also related to ticket #3083 ?

Saverio Proto

comment:2 Changed 10 years ago by bmilde@…

Sry, Its a duplicate of /ticket/2919.html

I temporarily solved this by moving the libncurses.so.5 away. (And moving it back after configure finshed). There is no trace of that issue in config.log and the problem comes after all configure checks have been passed. The configure script just complains about ncurses and no other library. It seems that it want to invoke something from ncurses from within the host system... and that is of course not big endian.

In this changeset was some effort to clean this issue: /changeset/10186.html

I played a bit with the lines (with no effect). If I remove them I get the same error.

comment:3 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with [10172]

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.