Modify

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#3127 closed defect (invalid)

Madwifi with WPA2: repeated deauthenticating due to local deauth request

Reported by: zobel@… Owned by: nbd
Priority: high Milestone:
Component: other Version:
Keywords: Cc:

Description

Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: associated
Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: deauthenticated due to local deauth request
Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: disassociated
Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: associated
Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: deauthenticated due to local deauth request
Feb  9 13:45:25 soekris daemon.info hostapd: ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: disassociated

/etc/config/wireless:

config wifi-device      wifi0
        option type atheros
        option channel 44
        option diversity 1
        option distance 100
        option txantenna 0
        option rxantenna 0
        option mode 11a
        
config wifi-iface
        option device wifi0
        option network wlan
        option mode ap 
        option ssid mysid
        option hidden 0
        option encryption psk2
        option key "mypassword"

/var/run/hostapd-ath0.conf:

driver=madwifi
interface=ath0

ssid=mysid
debug=1
wpa=2
wpa_pairwise=CCMP
wpa_passphrase=mypassword
root@soekris:/lib/wifi# iwpriv ath0 get_wpa
ath0      get_wpa:2  

root@soekris:/lib/wifi# iwpriv ath0 get_keymgtalgs
ath0      get_keymgtalgs:2  


root@soekris:/lib/wifi# grep KAMIKAZE /etc/banner
 KAMIKAZE (bleeding edge, r10407) -------------------

This is OpenWRT running on a Soekris net4801 with a Atheros MiniPCI card.
Remote machines are Debian Linux (Etch), IBM Thinkpad T41p and T60.

Attachments (0)

Change History (9)

comment:1 in reply to: ↑ description Changed 10 years ago by zobel@…

running hostapd on command line with -dddd /var/run/hostapd-ath0.conf gives me the following output:

Wireless event: cmd=0x8c04 len=20
ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: disassociated
Wireless event: cmd=0x8c03 len=20
ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: associated
  New STA
ath0: STA 00:19:7e:b2:1e:7f WPA: event 1 notification
madwifi_del_key: addr=00:19:7e:b2:1e:7f key_idx=0
ath0: STA 00:19:7e:b2:1e:7f WPA: start authentication
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state INITIALIZE
madwifi_del_key: addr=00:19:7e:b2:1e:7f key_idx=0
madwifi_set_sta_authorized: addr=00:19:7e:b2:1e:7f authorized=0
ath0: STA 00:19:7e:b2:1e:7f IEEE 802.1X: unauthorizing port
WPA: 00:19:7e:b2:1e:7f WPA_PTK_GROUP entering state IDLE
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state AUTHENTICATION
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state AUTHENTICATION2
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state INITPSK
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state PTKSTART
ath0: STA 00:19:7e:b2:1e:7f WPA: sending 1/4 msg of 4-Way Handshake
WPA: Send EAPOL(version=2 secure=0 mic=0 ack=1 install=0 pairwise=8 kde_len=0 keyidx=0 encr=0)
TX EAPOL - hexdump(len=113): 00 19 7e b2 1e 7f 00 02 6f 24 3a e1 88 8e 02 03 00 5f 02 00 8a 00 10 00 00 00 00 00 00 00 01 01 00 b2 41 2b bd ea b0 19 1f db a8 4b 5b ab 2b ac 8b c7 fc d1 3a 49 2b 31 57 01 22 ba 7d 43 79 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
IEEE 802.1X: 121 bytes from 00:19:7e:b2:1e:7f
   IEEE 802.1X: version=1 type=3 length=117
ath0: STA 00:19:7e:b2:1e:7f WPA: received EAPOL-Key frame (2/4 Pairwise)
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state PTKCALCNEGOTIATING
WPA: PTK derivation - A1=00:02:6f:24:3a:e1 A2=00:19:7e:b2:1e:7f
WPA: PMK - hexdump(len=32): [REMOVED]
WPA: PTK - hexdump(len=64): [REMOVED]
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state PTKCALCNEGOTIATING2
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state PTKINITNEGOTIATING
madwifi_get_seqnum: addr=00:00:00:00:00:00 idx=1
ath0: STA 00:19:7e:b2:1e:7f WPA: sending 3/4 msg of 4-Way Handshake
WPA: Send EAPOL(version=2 secure=1 mic=1 ack=1 install=1 pairwise=8 kde_len=46 keyidx=1 encr=1)
Plaintext EAPOL-Key Key Data - hexdump(len=56): [REMOVED]
TX EAPOL - hexdump(len=169): 00 19 7e b2 1e 7f 00 02 6f 24 3a e1 88 8e 02 03 00 97 02 13 ca 00 10 00 00 00 00 00 00 00 02 01 00 b2 41 2b bd ea b0 19 1f db a8 4b 5b ab 2b ac 8b c7 fc d1 3a 49 2b 31 57 01 22 ba 7d 43 79 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 d2 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 05 e1 29 40 48 b7 24 fb 05 8f 4a a4 33 93 5f a2 00 38 dc eb 58 7e d4 f1 76 91 17 e9 7b e1 cb da bf 8f 81 10 fa 5f 6f f1 f0 cd 7d d8 a2 cf 58 fd 5a 5e a6 79 c8 69 63 d1 47 74 f1 04 db 1a 0b 04 d3 ef 72 11 8b 3b ec 96 94 58
IEEE 802.1X: 99 bytes from 00:19:7e:b2:1e:7f
   IEEE 802.1X: version=1 type=3 length=95
ath0: STA 00:19:7e:b2:1e:7f WPA: received EAPOL-Key frame (4/4 Pairwise)
WPA: 00:19:7e:b2:1e:7f WPA_PTK entering state PTKINITDONE
madwifi_set_key: alg=CCMP addr=00:19:7e:b2:1e:7f key_idx=0
ioctl[IEEE80211_IOCTL_SETKEY]: Invalid argument
madwifi_set_key: Failed to set key (addr 00:19:7e:b2:1e:7f key_idx 0 alg 'CCMP' key_len 16 txkey 1)
hostapd_wpa_auth_disconnect: WPA authenticator requests disconnect: STA 00:19:7e:b2:1e:7f reason 2
madwifi_sta_deauth: addr=00:19:7e:b2:1e:7f reason_code=2
ath0: STA 00:19:7e:b2:1e:7f IEEE 802.11: deauthenticated due to local deauth request
Wireless event: cmd=0x8c02 len=99
Custom wireless event: 'STA-TRAFFIC-STAT
mac=00:19:7e:b2:1e:7f
rx_packets=2
rx_bytes=248
tx_packets=2
tx_bytes=270

I would say, it has something to do with:

ioctl[IEEE80211_IOCTL_SETKEY]: Invalid argument
madwifi_set_key: Failed to set key (addr 00:19:7e:b2:1e:7f key_idx 0 alg 'CCMP' key_len 16 txkey 1)

comment:2 follow-up: Changed 10 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to assigned

Please try cleaning hostapd and rebuilding it. Or was this a fresh checkout?

comment:3 in reply to: ↑ 2 Changed 10 years ago by anonymous

Replying to nbd:

Please try cleaning hostapd and rebuilding it. Or was this a fresh checkout?

Yeah, that fixed it. Though i still do not understand what made the problem. I svn up'd from r10103 to r10407 and did "make" and upgraded my soekris.

Thx for your help

comment:4 Changed 10 years ago by nbd

  • Resolution set to worksforme
  • Status changed from assigned to closed

The ABI for hostapd in MadWiFi changed, including the header files, but hostapd itself didn't. That's why it had to be rebuilt manually.

comment:5 Changed 10 years ago by Cisien

I am also getting this message and a very similar debug output. I am using Kamikaze 11264, and hostapd version 0.6.0 This is a clean SVN, I have tried re-building and re-installing just hostapd, also rebuild and re-installed the entire firmware. The only thing I have done is install hostapd and configure wireless

comment:6 Changed 10 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

request to re-open ticket

comment:7 Changed 10 years ago by blogic

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 Changed 9 years ago by esb

I can confirm this problem on a WRT54GL with 8.09 RC1 and RC2 (which uses b43), as can others in this thread, as well as numerous others. This problem does not seem to be limited to madwifi.

Please re-open.

comment:9 Changed 9 years ago by nbd

don't reopen. just because you see similar messages doesn't mean it has anything to do with the original issue.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.